summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-10-30 18:04:30 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-10-31 23:40:11 +0100
commitbbfb176d2d634bfd8747e014b8006d2fd0e98b4a (patch)
tree49bcbaac68076b19e5a89e765668186a46bf54ab /dev-util/mdds
parentnet-libs/aqbanking: 6.2.5 version bump (diff)
downloadgentoo-bbfb176d2d634bfd8747e014b8006d2fd0e98b4a.tar.gz
gentoo-bbfb176d2d634bfd8747e014b8006d2fd0e98b4a.tar.bz2
gentoo-bbfb176d2d634bfd8747e014b8006d2fd0e98b4a.zip
dev-util/mdds: 1.7.0 version bump
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-util/mdds')
-rw-r--r--dev-util/mdds/Manifest1
-rw-r--r--dev-util/mdds/files/mdds-1.7.0-bashism.patch75
-rw-r--r--dev-util/mdds/mdds-1.7.0.ebuild67
-rw-r--r--dev-util/mdds/mdds-9999.ebuild5
4 files changed, 145 insertions, 3 deletions
diff --git a/dev-util/mdds/Manifest b/dev-util/mdds/Manifest
index efa7eb91720d..4483da3da7c9 100644
--- a/dev-util/mdds/Manifest
+++ b/dev-util/mdds/Manifest
@@ -1 +1,2 @@
DIST mdds-1.6.0.tar.bz2 350406 BLAKE2B 70a99d779f318140f37bb3f873f1845c153f389a9e671a4d9ee4d1f0e762db312d536392061923c3c02494df6945a5a7743480eca1020d9cda6f3495888d7b00 SHA512 7c66894748e998f24374a5c6ea342ae2736e4bdba53be89510a1674690517ed7303786e1290fcfa26b07f236788c192ad29790129c228074397ab43699cdb290
+DIST mdds-1.7.0.tar.xz 313220 BLAKE2B 02ab09ad1338223da2911c05fc8d67c9d0d5414d1dcedac066dc95a2b0853f3801347c9791a5fc5700d666933be78efc52f735453769f9f2123ce06eca1fa67f SHA512 ac2bfe5186d499a79f4379c1dc7cc869bbbd9a59d4943399409dd4dd1ef7e3567a993deda5d5a06ad67dbd94b0a534439805837f2f405c5aca0aeb197178291a
diff --git a/dev-util/mdds/files/mdds-1.7.0-bashism.patch b/dev-util/mdds/files/mdds-1.7.0-bashism.patch
new file mode 100644
index 000000000000..3e94f32e8f8b
--- /dev/null
+++ b/dev-util/mdds/files/mdds-1.7.0-bashism.patch
@@ -0,0 +1,75 @@
+From 65da7c25f4d8204b1379a0afb46d82dc1b263ab0 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Thu, 28 May 2020 18:36:07 +0200
+Subject: [PATCH] Fix bashisms in configure.ac
+
+---
+ configure.ac | 14 +++++++-------
+ 1 file changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 00ab937..2282165 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -32,7 +32,7 @@ AC_ARG_ENABLE(debug-stdcxx,
+ ]
+ ,debug_stdcxx=yes)
+
+-AS_IF([test x"$debug_stdcxx" == "xyes"], [
++AS_IF([test x"$debug_stdcxx" = "xyes"], [
+ CXXFLAGS="$CXXFLAGS -D_GLIBCXX_DEBUG"
+ ])
+
+@@ -42,7 +42,7 @@ AC_ARG_ENABLE(release-tests,
+ ]
+ ,release_tests=yes)
+
+-AS_IF([test x"$release_tests" == "xyes"], [
++AS_IF([test x"$release_tests" = "xyes"], [
+ CXXFLAGS="$CXXFLAGS -DNDEBUG -O2"
+ ])
+
+@@ -56,11 +56,11 @@ AC_ARG_ENABLE(loop-unrolling,
+ [enable_loop_unrolling="$enableval"],[enable_loop_unrolling=yes]
+ )
+
+-AS_IF([test x"$enable_loop_unrolling" == "xno"], [
++AS_IF([test x"$enable_loop_unrolling" = "xno"], [
+ CXXFLAGS="$CXXFLAGS -DMDDS_LOOP_UNROLLING=0"
+ ])
+
+-AS_IF([test x"$enable_gcov" == "xyes"], [
++AS_IF([test x"$enable_gcov" = "xyes"], [
+ CXXFLAGS="$CXXFLAGS --coverage -O0"
+ ])
+
+@@ -69,7 +69,7 @@ AC_ARG_ENABLE(openmp,
+ [enable_openmp="$enableval"],[enable_openmp=yes]
+ )
+
+-AS_IF([test x"$enable_openmp" == "xyes"], [
++AS_IF([test x"$enable_openmp" = "xyes"], [
+ CXXFLAGS="$CXXFLAGS -fopenmp -DMDDS_USE_OPENMP=1"
+ LDFLAGS="$LDFLAGS -fopenmp"
+ ])
+@@ -79,7 +79,7 @@ AC_ARG_ENABLE(sanitizer-coverage,
+ [enable_sanitizer_coverage="$enableval"],[enable_sanitizer_coverage=no]
+ )
+
+-AS_IF([test x"$enable_sanitizer_coverage" == "xyes"], [
++AS_IF([test x"$enable_sanitizer_coverage" = "xyes"], [
+ CXXFLAGS="$CXXFLAGS -fprofile-instr-generate -fcoverage-mapping -O0"
+ ])
+
+@@ -122,7 +122,7 @@ AC_ARG_ENABLE([werror],
+ [enable_werror="$enableval"],
+ [enable_werror=no]
+ )
+-AS_IF([test x"$enable_werror" == "xyes"], [
++AS_IF([test x"$enable_werror" = "xyes"], [
+ CXXFLAGS="$CXXFLAGS -Werror"
+ ])
+
+--
+2.26.2
+
diff --git a/dev-util/mdds/mdds-1.7.0.ebuild b/dev-util/mdds/mdds-1.7.0.ebuild
new file mode 100644
index 000000000000..56bc179c30bc
--- /dev/null
+++ b/dev-util/mdds/mdds-1.7.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.com/mdds/mdds.git"
+ inherit git-r3
+else
+ SRC_URI="https://kohei.us/files/${PN}/src/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+fi
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Collection of multi-dimensional data structure and indexing algorithm"
+HOMEPAGE="https://gitlab.com/mdds/mdds"
+
+LICENSE="MIT"
+SLOT="1/1.5" # Check API version on version bumps!
+IUSE="doc openmp valgrind test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ doc? (
+ app-doc/doxygen
+ dev-python/sphinx
+ )
+ valgrind? ( dev-util/valgrind )
+"
+DEPEND="dev-libs/boost:="
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.5.0-buildsystem.patch"
+ "${FILESDIR}/${P}-bashism.patch" # bug 723094
+)
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable doc docs)
+ $(use_enable valgrind memory_tests)
+ )
+ if use openmp && tc-has-openmp; then
+ myeconfargs+=( --enable-openmp )
+ else
+ myeconfargs+=( --disable-openmp )
+ fi
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ tc-export CXX
+ default
+}
diff --git a/dev-util/mdds/mdds-9999.ebuild b/dev-util/mdds/mdds-9999.ebuild
index 64e78d4d68f9..37a5d8728339 100644
--- a/dev-util/mdds/mdds-9999.ebuild
+++ b/dev-util/mdds/mdds-9999.ebuild
@@ -7,12 +7,12 @@ if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://gitlab.com/mdds/mdds.git"
inherit git-r3
else
- SRC_URI="https://kohei.us/files/${PN}/src/${P}.tar.bz2"
+ SRC_URI="https://kohei.us/files/${PN}/src/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
fi
inherit autotools toolchain-funcs
-DESCRIPTION="A collection of multi-dimensional data structure and indexing algorithm"
+DESCRIPTION="Collection of multi-dimensional data structure and indexing algorithm"
HOMEPAGE="https://gitlab.com/mdds/mdds"
LICENSE="MIT"
@@ -60,6 +60,5 @@ src_configure() {
src_test() {
tc-export CXX
-
default
}