summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <holgersson@posteo.de>2020-03-02 23:24:24 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-03-16 22:25:43 +0100
commit9d366f6c2acc6f0e770b501ca1b077e29140fc34 (patch)
tree630f375c4fa9f3d281ac43c301828d24a31e5b32 /dev-util/mdds
parentapp-office/libreoffice: Pin dev-libs/liborcus, dev-util/mdds versions (diff)
downloadgentoo-9d366f6c2acc6f0e770b501ca1b077e29140fc34.tar.gz
gentoo-9d366f6c2acc6f0e770b501ca1b077e29140fc34.tar.bz2
gentoo-9d366f6c2acc6f0e770b501ca1b077e29140fc34.zip
dev-util/mdds: Bump to 1.5.0
Note: Avoid the bump to 1.6.0 as upstream forgot to bump the version in paths. This bump also updates general ebuild style, adds the QA test for tests and drops the src_compile() function. Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Nils Freydank <holgersson@posteo.de> Closes: https://github.com/gentoo/gentoo/pull/14825 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-util/mdds')
-rw-r--r--dev-util/mdds/Manifest1
-rw-r--r--dev-util/mdds/files/mdds-1.5.0-buildsystem.patch39
-rw-r--r--dev-util/mdds/mdds-1.5.0.ebuild53
3 files changed, 93 insertions, 0 deletions
diff --git a/dev-util/mdds/Manifest b/dev-util/mdds/Manifest
index 6af7c94a04a8..c2d2a2288a4a 100644
--- a/dev-util/mdds/Manifest
+++ b/dev-util/mdds/Manifest
@@ -1 +1,2 @@
DIST mdds-1.4.3.tar.bz2 334515 BLAKE2B 3a42b7858346b2907040b8e42b1fae56626fc0881737ed04e20ffe4f9a23d2a2459c45e4244ac77745d2b1c7e3ff1642fe883b16def36e56c5c3d15077445793 SHA512 fd54a93fde89bff74a5ccf84ce5e2e002114297b165ded56a1bae92b28d70864775add140e165c7750f7dbe8ca1bfe83179cd9a835e53312c2e893c9e1f4434c
+DIST mdds-1.5.0.tar.bz2 346888 BLAKE2B c5c33649b6d8ba7d289eafe39c00c4334caa04f2a619d396e4f2499db9d66f48cb3ad0081805e7cef93bda49c24e6ce1a50c85a5e738120ee575c319959f6129 SHA512 9ed434dbc00285defbf3e0989396a1b52439bfdda01e5fd5822fef5e42e2c9b0b9436dd11b99af84a09a1965191ec106114e4046834f5b733474759f43bbfd95
diff --git a/dev-util/mdds/files/mdds-1.5.0-buildsystem.patch b/dev-util/mdds/files/mdds-1.5.0-buildsystem.patch
new file mode 100644
index 000000000000..113581a8de63
--- /dev/null
+++ b/dev-util/mdds/files/mdds-1.5.0-buildsystem.patch
@@ -0,0 +1,39 @@
+# Nils Freydank <holgersson@posteo.de> (2020-01-08)
+Avoid auto installation of files we install later manually.
+Adopted from asturm's patch for mdds-1.4.3.
+
+--- a/Makefile.am 2020-02-08 20:00:00.000000000 +0100
++++ b/Makefile.am 2020-02-08 20:00:00.000000001 +0100
+@@ -4,7 +4,6 @@
+
+ AM_CPPFLAGS = -I$(top_srcdir)/include $(CXXFLAGS_UNITTESTS)
+
+-dist_doc_DATA = AUTHORS README.md
+ nodist_pkgconf_DATA = misc/mdds-@API_VERSION@.pc
+
+ DISTCLEANFILES = \
+@@ -14,8 +13,6 @@
+
+ EXTRA_DIST = \
+ autogen.sh \
+- CHANGELOG \
+- LICENSE \
+ doc/conf.py \
+ doc/doxygen.conf \
+ doc/flat_segment_tree.rst \
+@@ -164,14 +161,6 @@
+ rtree_test_bulkload_mem.mem
+ endif
+
+-install-data-local:
+- $(MKDIR_P) $(DESTDIR)$(docdir)
+- $(INSTALL_DATA) $(top_srcdir)/LICENSE $(DESTDIR)$(docdir)/COPYING
+- $(INSTALL_DATA) $(top_srcdir)/CHANGELOG $(DESTDIR)$(docdir)/NEWS
+-
+-uninstall-local:
+- rm -f $(DESTDIR)$(docdir)/COPYING $(DESTDIR)$(docdir)/NEWS
+-
+ if BUILD_DOCS
+ html-local:
+ (cd doc && $(DOXYGEN) doxygen.conf)
+
diff --git a/dev-util/mdds/mdds-1.5.0.ebuild b/dev-util/mdds/mdds-1.5.0.ebuild
new file mode 100644
index 000000000000..3b7f1556f29a
--- /dev/null
+++ b/dev-util/mdds/mdds-1.5.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.com/mdds/mdds.git"
+ inherit git-r3
+else
+ SRC_URI="https://kohei.us/files/${PN}/src/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+fi
+inherit autotools toolchain-funcs
+
+DESCRIPTION="A collection of multi-dimensional data structure and indexing algorithm"
+HOMEPAGE="https://gitlab.com/mdds/mdds"
+
+LICENSE="MIT"
+SLOT="1/${PV%.*}"
+IUSE="doc valgrind test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ doc? (
+ app-doc/doxygen
+ dev-python/sphinx
+ )
+ valgrind? ( dev-util/valgrind )
+"
+DEPEND="dev-libs/boost:="
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-buildsystem.patch" )
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable doc docs)
+ $(use_enable valgrind memory_tests)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ tc-export CXX
+
+ default
+}