summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/lttng-tools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/lttng-tools')
-rw-r--r--dev-util/lttng-tools/Manifest3
-rw-r--r--dev-util/lttng-tools/lttng-tools-2.5.0.ebuild38
-rw-r--r--dev-util/lttng-tools/lttng-tools-2.5.2.ebuild38
-rw-r--r--dev-util/lttng-tools/lttng-tools-2.6.0_rc3.ebuild38
-rw-r--r--dev-util/lttng-tools/metadata.xml15
5 files changed, 132 insertions, 0 deletions
diff --git a/dev-util/lttng-tools/Manifest b/dev-util/lttng-tools/Manifest
new file mode 100644
index 000000000000..df1c1c0a926d
--- /dev/null
+++ b/dev-util/lttng-tools/Manifest
@@ -0,0 +1,3 @@
+DIST lttng-tools-2.5.0.tar.bz2 867879 SHA256 dad8b8f9d7209dcf91b2bf6ec34a0b31d1cf3c6a81698492a6e9cff2d11e1ca7 SHA512 91ccdcd2f02999c97bb218147aab28a4e8c5e6b4813e97c690da965f8f54c312fc1e0487a200558e2101938096f2ba3e22f09fbbcd6b7abcdd800215f328dfd5 WHIRLPOOL d9af3d5c4267acaadb5296db42322e7a475e1366f4ff7f83b3dcfe7fa5507261eb938920c2bdc95395eff528a1022cee33665f1781a2172958b4e57d96ab764c
+DIST lttng-tools-2.5.2.tar.bz2 876344 SHA256 1f52d342fb5b56a6675748f0b8e8557ec7c4e90732c3d8f5732bd10b920b233d SHA512 c556b54d1b571f9f5e3b95b729536ada179d899227b6fd0f0fb3482572ca775d4d8212aab4782d6048587df225846d90ba947730e1ca0101f4c54de0819f421d WHIRLPOOL e0552e68a2c3b4c50cefafd600c1dd6e5e586e16eb1c64d5b0b6749e197a754a982f2e8a3915ab5f76f92295cb4bcb9a20266a32a178bfbc4adc4c14a3ec3206
+DIST lttng-tools-2.6.0-rc3.tar.bz2 913287 SHA256 c11d6158d8865b6329d9e1eabc938fc81f33b18634d7c9a2a27a82cea1c63f2d SHA512 db40ee1fe0ec7d93a7e35a742f945cbb89399f56c406f276512e5f9a44907ce0dd195c5f6d763adb13015c8beef74e09019ca3535d7be619dd072e5cf5650dab WHIRLPOOL aa331e76cd4f9b035a50a2b65778cf602f9c7f34d318338d2ad20baa95cb798a9077518966fc4a14b5e288be21246ec9ac403c2fca2b37e277e26d0091bb0e48
diff --git a/dev-util/lttng-tools/lttng-tools-2.5.0.ebuild b/dev-util/lttng-tools/lttng-tools-2.5.0.ebuild
new file mode 100644
index 000000000000..b2fdfcd49ec0
--- /dev/null
+++ b/dev-util/lttng-tools/lttng-tools-2.5.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit linux-info
+
+MY_P="${P/_rc/-rc}"
+DESCRIPTION="Linux Trace Toolkit - next generation"
+HOMEPAGE="http://lttng.org"
+SRC_URI="http://lttng.org/files/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ust"
+
+DEPEND="dev-libs/userspace-rcu
+ dev-libs/popt
+ dev-libs/libxml2
+ ust? ( dev-util/lttng-ust )
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_pretend() {
+ if kernel_is -lt 2 6 27; then
+ ewarn "${PN} require Linux kernel >= 2.6.27"
+ ewarn " pipe2(), epoll_create1() and SOCK_CLOEXEC are needed to run"
+ ewarn " the session daemon. There were introduce in the 2.6.27"
+ fi
+}
+
+src_configure() {
+ econf $(use_enable ust lttng-ust)
+}
diff --git a/dev-util/lttng-tools/lttng-tools-2.5.2.ebuild b/dev-util/lttng-tools/lttng-tools-2.5.2.ebuild
new file mode 100644
index 000000000000..b2fdfcd49ec0
--- /dev/null
+++ b/dev-util/lttng-tools/lttng-tools-2.5.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit linux-info
+
+MY_P="${P/_rc/-rc}"
+DESCRIPTION="Linux Trace Toolkit - next generation"
+HOMEPAGE="http://lttng.org"
+SRC_URI="http://lttng.org/files/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ust"
+
+DEPEND="dev-libs/userspace-rcu
+ dev-libs/popt
+ dev-libs/libxml2
+ ust? ( dev-util/lttng-ust )
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_pretend() {
+ if kernel_is -lt 2 6 27; then
+ ewarn "${PN} require Linux kernel >= 2.6.27"
+ ewarn " pipe2(), epoll_create1() and SOCK_CLOEXEC are needed to run"
+ ewarn " the session daemon. There were introduce in the 2.6.27"
+ fi
+}
+
+src_configure() {
+ econf $(use_enable ust lttng-ust)
+}
diff --git a/dev-util/lttng-tools/lttng-tools-2.6.0_rc3.ebuild b/dev-util/lttng-tools/lttng-tools-2.6.0_rc3.ebuild
new file mode 100644
index 000000000000..b2fdfcd49ec0
--- /dev/null
+++ b/dev-util/lttng-tools/lttng-tools-2.6.0_rc3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit linux-info
+
+MY_P="${P/_rc/-rc}"
+DESCRIPTION="Linux Trace Toolkit - next generation"
+HOMEPAGE="http://lttng.org"
+SRC_URI="http://lttng.org/files/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ust"
+
+DEPEND="dev-libs/userspace-rcu
+ dev-libs/popt
+ dev-libs/libxml2
+ ust? ( dev-util/lttng-ust )
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_pretend() {
+ if kernel_is -lt 2 6 27; then
+ ewarn "${PN} require Linux kernel >= 2.6.27"
+ ewarn " pipe2(), epoll_create1() and SOCK_CLOEXEC are needed to run"
+ ewarn " the session daemon. There were introduce in the 2.6.27"
+ fi
+}
+
+src_configure() {
+ econf $(use_enable ust lttng-ust)
+}
diff --git a/dev-util/lttng-tools/metadata.xml b/dev-util/lttng-tools/metadata.xml
new file mode 100644
index 000000000000..c177fda161df
--- /dev/null
+++ b/dev-util/lttng-tools/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>dlan@gentoo.org</email>
+ <name>Yixun Lan</name>
+ </maintainer>
+
+ <longdescription>
+ LTTng, the Linux Trace Toolkit Next Generation, is a project that aims at producing a highly efficient full system tracing solution
+ </longdescription>
+ <use>
+ <flag name='ust'>Support LTTng-UST (Userspace Tracing)</flag>
+ </use>
+</pkgmetadata>