summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-09-15 16:38:20 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-09-15 16:38:51 +0200
commit601b2a9491e03f3982c757c3a03a8cabc6ee212b (patch)
tree543bd73267099b0f3a2031fd26152606442152a1 /dev-util/intel-graphics-system-controller
parentdev-libs/intel-metrics-library: add 1.0.173 (diff)
downloadgentoo-601b2a9491e03f3982c757c3a03a8cabc6ee212b.tar.gz
gentoo-601b2a9491e03f3982c757c3a03a8cabc6ee212b.tar.bz2
gentoo-601b2a9491e03f3982c757c3a03a8cabc6ee212b.zip
dev-util/intel-graphics-system-controller: add 0.9.3
Reported-by: Alfred Persson Forsberg <cat@catcream.org> Signed-off-by: Conrad Kostecki <conikost@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/38463
Diffstat (limited to 'dev-util/intel-graphics-system-controller')
-rw-r--r--dev-util/intel-graphics-system-controller/Manifest1
-rw-r--r--dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.9.3.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-util/intel-graphics-system-controller/Manifest b/dev-util/intel-graphics-system-controller/Manifest
index d557612f10f4..7733559f327d 100644
--- a/dev-util/intel-graphics-system-controller/Manifest
+++ b/dev-util/intel-graphics-system-controller/Manifest
@@ -1 +1,2 @@
DIST intel-graphics-system-controller-0.8.16.tar.gz 192027 BLAKE2B fc97dffcffe53b92fa03b9fbcaa2f784f3fd33e4cdfa2f85548d2f6bea60bdf1868b003a45448829685fd961f9699534781de3ce43703a378168d50bf14927ce SHA512 105950a44c3b756fa4c23aa1590e2c0ae2f83af87660af14889641465433903a9e2973c8689338a716e67799098a762885933ba53c4a8de72ca4be3dbb134a84
+DIST intel-graphics-system-controller-0.9.3.tar.gz 206474 BLAKE2B 3af1caeed8d553b017f333ddacfbccb28e6d0f370ebc93b890686417fa400fb227f46cb83cfd686808a5e308ebbc2b2534b318ea4ba8a94a237b721e0ef5be37 SHA512 758059556efa6b94702291d11ca8267a3e4258299a324388c4a8fcb9efd2a2218ad354447ea32277439fc65d52f9481441d0bd699bfae1c375b7f807e21f9d94
diff --git a/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.9.3.ebuild b/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.9.3.ebuild
new file mode 100644
index 000000000000..358f6dec3c36
--- /dev/null
+++ b/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.9.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="igsc"
+MY_P="${MY_PN}-${PV}"
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit cmake python-any-r1
+
+DESCRIPTION="Intel graphics system controller firmware update library"
+HOMEPAGE="https://github.com/intel/igsc"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/refs/tags/V${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+cli doc"
+
+RDEPEND=">=dev-libs/metee-3.2.4:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? (
+ ${PYTHON_DEPS}
+ app-text/doxygen
+ $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]')
+ )
+"
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CLI="$(usex cli)"
+ -DENABLE_DOCS="$(usex doc)"
+ -DENABLE_PERF="OFF"
+ -DENABLE_WERROR="OFF"
+
+ # If enabled, tests are automatically run during
+ # the compile phase and we cannot run them because
+ # they require permissions to access the hardware.
+ -DENABLE_TESTS="OFF"
+ )
+
+ cmake_src_configure
+}