summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2024-09-26 08:51:54 -0400
committerMike Pagano <mpagano@gentoo.org>2024-09-26 08:51:54 -0400
commit653078d30bf0a68b38139876c5991536703e1d6d (patch)
tree4d6aff8f58c504f2f99f4dc55598acb3c33fba47 /dev-util/idea-community
parentdev-util/idea-community: add 2024.2.3 (diff)
downloadgentoo-653078d30bf0a68b38139876c5991536703e1d6d.tar.gz
gentoo-653078d30bf0a68b38139876c5991536703e1d6d.tar.bz2
gentoo-653078d30bf0a68b38139876c5991536703e1d6d.zip
dev-util/idea-community: drop 2024.2.2
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'dev-util/idea-community')
-rw-r--r--dev-util/idea-community/Manifest2
-rw-r--r--dev-util/idea-community/idea-community-2024.2.2.ebuild135
2 files changed, 0 insertions, 137 deletions
diff --git a/dev-util/idea-community/Manifest b/dev-util/idea-community/Manifest
index b416a7e80ea7..99d493638e07 100644
--- a/dev-util/idea-community/Manifest
+++ b/dev-util/idea-community/Manifest
@@ -1,4 +1,2 @@
-DIST idea-community-2024.2.2-aarch64.tar.gz 880446157 BLAKE2B 918c25046e61b59298f28bf8d290f9c50b74a89c59377023028019401fcce5b00f5cf21edccb84ed1d57ec63b9594dcf64b81aed59060422ee27ac970b47adf6 SHA512 41741760874ff2399f875c9ff148c5b88e6911df6118d002922fc7cde4290e93799cf510ec5f5f4cb6a3ea1e774d67a4f5e18b952c14fa93934a52c5888ccc49
-DIST idea-community-2024.2.2-amd64.tar.gz 881086769 BLAKE2B b95d3dcc6fa631b089215842d286ae2f2414c4f684d1d7a94c95bb2c94942fbdef563962ad3079dba62909f45a3182a64eec34c928f40f784c468920089b9261 SHA512 a57e5f58b2e65d0f421ded334696fa28d1ee748d7cf8ceb0ad10781a68cd4d9350e83d46376b17c15d312294f6155026e83209e678adf7f507874f455a68bbdc
DIST idea-community-2024.2.3-aarch64.tar.gz 880579524 BLAKE2B f60114f4f5e9a344bcd8a94ddeaa929b6f2981b1d748a8a8c60749cd5c0b71a266e55b7e4ec29828442467abd359f31dc87a11f008c7e7b2beb2dc474b75c7be SHA512 94aa65f7082b4ddbd53faa955f6a9eaf93f121200c3c55dcb9a9c6b52ead2f192fe8a99000d6979e31747af645a0d3b67e6699ec025dbb7b9ee0101ea633ef69
DIST idea-community-2024.2.3-amd64.tar.gz 881193694 BLAKE2B 4c7af9a748bbebe9b4c6702c512a5c99d8bbd1d8b19ce596e2a51cbe77d3172c8679062c13f2afacb0f315618d2626a453b1512f227fe24d40df6498a5e3a6eb SHA512 4b8caf3ee62fa6cf1e725f270d330c184222425eb68231d545bd377d16c0a30257e1acf2ce2031a53b7cea948f7f17aede6790ee29225529902a39e724ef0e51
diff --git a/dev-util/idea-community/idea-community-2024.2.2.ebuild b/dev-util/idea-community/idea-community-2024.2.2.ebuild
deleted file mode 100644
index b61f2c92242b..000000000000
--- a/dev-util/idea-community/idea-community-2024.2.2.ebuild
+++ /dev/null
@@ -1,135 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit desktop wrapper
-
-MY_PV=$(ver_cut 1-3)
-
-DESCRIPTION="A complete toolset for web, mobile and enterprise development"
-HOMEPAGE="https://www.jetbrains.com/idea"
-
-SRC_URI="
- amd64? ( https://download.jetbrains.com/idea/ideaIC-${MY_PV}.tar.gz -> ${P}-amd64.tar.gz )
- arm64? ( https://download.jetbrains.com/idea/ideaIC-${MY_PV}-aarch64.tar.gz -> ${P}-aarch64.tar.gz )
- "
-
-S="${WORKDIR}/idea-IC-${PV}"
-LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 CC-BY-2.5 CDDL-1.1
- codehaus-classworlds CPL-1.0 EPL-1.0 EPL-2.0
- GPL-2 GPL-2-with-classpath-exception ISC
- JDOM LGPL-2.1 LGPL-2.1+ LGPL-3-with-linking-exception MIT
- MPL-1.0 MPL-1.1 OFL-1.1 ZLIB"
-
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-
-DEPEND="
- || (
- >=dev-java/openjdk-17.0.8.1_p1:17
- >=dev-java/openjdk-bin-17.0.8.1_p1:17
- )"
-
-RDEPEND="${DEPEND}
- sys-libs/glibc
- media-libs/harfbuzz
- dev-java/jansi-native
- dev-libs/libdbusmenu"
-
-BDEPEND="dev-util/patchelf"
-RESTRICT="splitdebug"
-
-QA_PREBUILT="opt/${PN}/*"
-
-src_unpack() {
-
- default_src_unpack
- if [ ! -d "$S" ]; then
- einfo "Renaming source directory to predictable name..."
- mv $(ls "${WORKDIR}") "idea-IC-${PV}" || die
- fi
-}
-
-src_prepare() {
-
- default_src_prepare
-
- if use amd64; then
- JRE_DIR=jre64
- rm -vf "${S}"/plugins/cwm-plugin/quiche-native/linux-aarch64/libquiche.so
- else
- JRE_DIR=jre
- rm -vf "${S}"/plugins/cwm-plugin/quiche-native/linux-x86-64/libquiche.so
- fi
-
- PLUGIN_DIR="${S}/${JRE_DIR}/lib/"
-
- # rm LLDBFrontEnd after licensing questions with Gentoo License Team
- rm -vf "${S}"/plugins/Kotlin/bin/linux/LLDBFrontend
- rm -vf ${PLUGIN_DIR}/libavplugin*
- rm -vf "${S}"/plugins/maven/lib/maven3/lib/jansi-native/*/libjansi*
- rm -vrf "${S}"/lib/pty4j-native/linux/ppc64le
- rm -vf "${S}"/bin/libdbm64*
- rm -vf "${S}"/lib/pty4j-native/linux/mips64el/libpty.so
-
- if [[ -d "${S}"/"${JRE_DIR}" ]]; then
- for file in "${PLUGIN_DIR}"/{libfxplugins.so,libjfxmedia.so}
- do
- if [[ -f "$file" ]]; then
- patchelf --set-rpath '$ORIGIN' $file || die
- fi
- done
- fi
-
- rm -vf "${S}"/lib/pty4j-native/linux/x86-64/libpty.so
-
- sed -i \
- -e "\$a\\\\" \
- -e "\$a#-----------------------------------------------------------------------" \
- -e "\$a# Disable automatic updates as these are handled through Gentoo's" \
- -e "\$a# package manager. See bug #704494" \
- -e "\$a#-----------------------------------------------------------------------" \
- -e "\$aide.no.platform.update=Gentoo" bin/idea.properties
-
- eapply_user
-}
-
-src_install() {
- local dir="/opt/${PN}"
- local dst="${D}${dir}"
-
- insinto "${dir}"
- doins -r *
- fperms 755 "${dir}"/bin/{format.sh,idea,idea.sh,inspect.sh,restarter,fsnotifier}
- if use amd64; then
- JRE_DIR=jre
- JRE_DIR=jre
- fi
-
- JRE_BINARIES="jaotc java javapackager jjs jrunscript keytool pack200 rmid rmiregistry unpack200"
- if [[ -d ${JRE_DIR} ]]; then
- for jrebin in $JRE_BINARIES; do
- fperms 755 "${dir}"/"${JRE_DIR}"/bin/"${jrebin}"
- done
- fi
-
- # bundled script is always lowercase, and doesn't have -ultimate, -professional suffix.
- local bundled_script_name="${PN%-*}.sh"
- make_wrapper "${PN}" "${dir}/bin/$bundled_script_name" || die
-
- local pngfile="$(find ${dst}/bin -maxdepth 1 -iname '*.png')"
- newicon $pngfile "${PN}.png" || die "we died"
-
- make_desktop_entry "/opt/idea-community/bin/idea" "IntelliJ Idea Community Edition" "${PN}" "Development;IDE;"
-
- # recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
- mkdir -p "${D}/etc/sysctl.d/" || die
- echo "fs.inotify.max_user_watches = 524288" > "${D}/etc/sysctl.d/30-idea-inotify-watches.conf" || die
-
- # remove bundled harfbuzz
- rm -f "${D}"/lib/libharfbuzz.so || die "Unable to remove bundled harfbuzz"
-
- # remove bundled java
- rm -r ${dst}/jbr || die "Unable to remove bundled java"
-
-}