summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-10-01 18:12:40 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-10-01 18:15:46 +0200
commitac63c1c9dfb013194deabe3cad57619cab6c1a1e (patch)
tree90bb84d31ac3fcd0632afb826b9c9fd8c92eb104 /dev-util/icemon/icemon-3.1.0.ebuild
parentmedia-gfx/wally: Drop USE=kde, ebuild makeover, bug #629032 (diff)
downloadgentoo-ac63c1c9dfb013194deabe3cad57619cab6c1a1e.tar.gz
gentoo-ac63c1c9dfb013194deabe3cad57619cab6c1a1e.tar.bz2
gentoo-ac63c1c9dfb013194deabe3cad57619cab6c1a1e.zip
dev-util/icemon: 3.1.0 Qt5-based version bump, bug #629038
EAPI=6, new HOMEPAGE, SRC_URI Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'dev-util/icemon/icemon-3.1.0.ebuild')
-rw-r--r--dev-util/icemon/icemon-3.1.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-util/icemon/icemon-3.1.0.ebuild b/dev-util/icemon/icemon-3.1.0.ebuild
new file mode 100644
index 000000000000..bdf10ab714f8
--- /dev/null
+++ b/dev-util/icemon/icemon-3.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Monitor program for use with Icecream compile clusters based on KDE Frameworks"
+HOMEPAGE="https://en.opensuse.org/Icecream https://github.com/icecc/icemon"
+SRC_URI="https://github.com/icecc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ sys-devel/icecream
+"
+DEPEND="${RDEPEND}
+ app-text/docbook2X
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=OFF
+ )
+ cmake-utils_src_configure
+}