summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/huc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/huc')
-rw-r--r--dev-util/huc/Manifest1
-rw-r--r--dev-util/huc/huc-0.1.ebuild32
-rw-r--r--dev-util/huc/metadata.xml7
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/huc/Manifest b/dev-util/huc/Manifest
new file mode 100644
index 000000000000..efc4fd9b525f
--- /dev/null
+++ b/dev-util/huc/Manifest
@@ -0,0 +1 @@
+DIST huc-0.1.tar.bz2 8367 SHA256 2966c25164ec4cfa81557ccf30ddf1b2f3ccd37f1362c7a2580c4d81d44298f0 SHA512 711266edfdec572aad877230653248b02cc0b989f1cf2766bf6cc4e196dcd02ba4bf148849d360457fc396de18f0bd0b6f7a26ba3c13a159cf26ece7c356c225 WHIRLPOOL 0f4b66bdd6ce39ad2dbe55f0916c2baea50d5eb9051488ae5269db26a729e8d944a2647f960f9f870f1d82ba97d4dd4d6dbbb11d57e45ec5f833ca3932fba7f4
diff --git a/dev-util/huc/huc-0.1.ebuild b/dev-util/huc/huc-0.1.ebuild
new file mode 100644
index 000000000000..ef3eb84a5251
--- /dev/null
+++ b/dev-util/huc/huc-0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="HTML umlaut conversion tool"
+SRC_URI="http://www.int21.de/huc/${P}.tar.bz2"
+HOMEPAGE="http://www.int21.de/huc/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ppc sparc x86 ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND=""
+
+doecho() {
+ echo "$@"
+ "$@"
+}
+
+src_compile() {
+ doecho $(tc-getCXX) \
+ ${LDFLAGS} ${CXXFLAGS} \
+ -o ${PN} ${PN}.cpp || die "compile failed"
+}
+
+src_install () {
+ dobin huc || die "dobin failed"
+ dodoc README
+}
diff --git a/dev-util/huc/metadata.xml b/dev-util/huc/metadata.xml
new file mode 100644
index 000000000000..d9cd2cad66c2
--- /dev/null
+++ b/dev-util/huc/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>