summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2023-11-18 22:54:50 +0800
committerBenda Xu <heroxbd@gentoo.org>2023-12-14 23:01:47 +0800
commit5297819d6d04e8608d329a12afa05dd68ea4f10f (patch)
treec769483e0d38d04669d94df43b3698bd0507f4bc /dev-util/hip/files
parentrocm.eclass: add ROCM_SKIP_GLOBALS for the USE-flags exposure. (diff)
downloadgentoo-5297819d6d04e8608d329a12afa05dd68ea4f10f.tar.gz
gentoo-5297819d6d04e8608d329a12afa05dd68ea4f10f.tar.bz2
gentoo-5297819d6d04e8608d329a12afa05dd68ea4f10f.zip
dev-util/hip: include test suit.
The dev-util/hip upstream has separated its test cases into a full git repository with an independent build system. To run the test cases, we have to call cmake twice in every src_* phase. I come up with a wrapper to hack CMAKE_USE_DIR and BUILD_DIR values. Ignore vulkan tests before someone could figure out how to properly run them. Reference: https://github.com/ROCm-Developer-Tools/HIP/issues/3292 Closes: https://github.com/gentoo/gentoo/pull/33906 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'dev-util/hip/files')
-rw-r--r--dev-util/hip/files/hip-test-5.7.0-rocm_agent_enumerator-location.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/dev-util/hip/files/hip-test-5.7.0-rocm_agent_enumerator-location.patch b/dev-util/hip/files/hip-test-5.7.0-rocm_agent_enumerator-location.patch
new file mode 100644
index 000000000000..1d967212ac9a
--- /dev/null
+++ b/dev-util/hip/files/hip-test-5.7.0-rocm_agent_enumerator-location.patch
@@ -0,0 +1,15 @@
+In Gentoo rocm_agent_enumerator is installed by rocminfo and is in PATH.
+
+--- catch/CMakeLists.txt~ 2023-11-18 13:56:08.000000000 +0800
++++ catch/CMakeLists.txt 2023-11-18 13:59:28.136170638 +0800
+@@ -182,9 +182,8 @@
+ # rocm_agent_enumerator
+ if(NOT DEFINED OFFLOAD_ARCH_STR
+ AND NOT DEFINED ENV{HCC_AMDGPU_TARGET}
+- AND EXISTS "${ROCM_PATH}/bin/rocm_agent_enumerator"
+ AND HIP_PLATFORM STREQUAL "amd" AND UNIX)
+- execute_process(COMMAND ${ROCM_PATH}/bin/rocm_agent_enumerator
++ execute_process(COMMAND rocm_agent_enumerator
+ OUTPUT_VARIABLE HIP_GPU_ARCH
+ RESULT_VARIABLE ROCM_AGENT_ENUM_RESULT)
+ # Trim out gfx000