summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2022-03-14 08:28:43 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-03-14 09:00:06 +0200
commit9b5e7dc4f07f11bc3f9a7004030461c6ec49aa81 (patch)
tree53d4f71bd26635269b3f86e97a2106aaf01e2338 /dev-util/hfstospell
parentmedia-gfx/prusaslicer: drop old (diff)
downloadgentoo-9b5e7dc4f07f11bc3f9a7004030461c6ec49aa81.tar.gz
gentoo-9b5e7dc4f07f11bc3f9a7004030461c6ec49aa81.tar.bz2
gentoo-9b5e7dc4f07f11bc3f9a7004030461c6ec49aa81.zip
dev-util/hfstospell: add 0.5.3
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-util/hfstospell')
-rw-r--r--dev-util/hfstospell/Manifest1
-rw-r--r--dev-util/hfstospell/hfstospell-0.5.3.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-util/hfstospell/Manifest b/dev-util/hfstospell/Manifest
index fd7d9e959c93..7f331cb0510e 100644
--- a/dev-util/hfstospell/Manifest
+++ b/dev-util/hfstospell/Manifest
@@ -1 +1,2 @@
DIST hfstospell-0.5.2.tar.gz 152115 BLAKE2B 667c01672fd6fd6ee743a6542677ffe74e3900c27ab2754f8fa7dcc57081074bd98e8d82827fe176b2a6c9abc4565efcb3204df43110906f5a333405ec8a6bf2 SHA512 307aff3aec91ac6ffed3ebabdc2baa1a6e913431f57a80a0d0254be57fbd72e28d7592c35e0d72e5979f7e0b4c585f11b8eb91183b0877f9670a9cd5206c0140
+DIST hfstospell-0.5.3.tar.gz 152654 BLAKE2B f77c86e18b9dcb098460bdaec2f6a148b4bf515670aad3d17002b3027026483658d0df924a5d71b12251128ba89bee3a9d7c1d03a5983830accf0340445a1331 SHA512 f25bae6c083894139ba1e3dbd24f010e1c4695bdfe4c2499d31f2f0bd2f5688b662ea15666b46f174fc75f0aa6f5cd114456f735b1d49bcf33322221b6f57ff5
diff --git a/dev-util/hfstospell/hfstospell-0.5.3.ebuild b/dev-util/hfstospell/hfstospell-0.5.3.ebuild
new file mode 100644
index 000000000000..fb0ae63f8f3a
--- /dev/null
+++ b/dev-util/hfstospell/hfstospell-0.5.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="HFST spell checker library and command line tool"
+HOMEPAGE="https://github.com/hfst/hfst-ospell"
+SRC_URI="https://github.com/hfst/hfst-ospell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="clang"
+
+DEPEND="app-arch/libarchive:=
+ dev-libs/icu:=
+ !clang? (
+ dev-cpp/glibmm:2
+ dev-cpp/libxmlpp:2.6
+ dev-libs/glib:2
+ dev-libs/libsigc++:2
+ dev-libs/libxml2
+ )"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/hfst-ospell-${PV}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # https://github.com/hfst/hfst-ospell/issues/48
+ if tc-is-clang; then
+ econf --without-libxmlpp --without-tinyxml2
+ elif use clang; then
+ econf --without-libxmlpp --without-tinyxml2
+ else
+ default
+ fi
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete -o -name '*.a' -delete || die
+}