summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2020-09-20 01:00:00 +0000
committerMike Gilbert <floppym@gentoo.org>2020-09-21 12:05:37 -0400
commit17a5eec31983efe168a5e157f58b59fd736fb4e7 (patch)
treeca38a8034d89035efff2a446a9b4616400f2ff90 /dev-util/gyp/gyp-20200512145953.ebuild
parentdev-util/gyp: Version bump (20200512145953). (diff)
downloadgentoo-17a5eec31983efe168a5e157f58b59fd736fb4e7.tar.gz
gentoo-17a5eec31983efe168a5e157f58b59fd736fb4e7.tar.bz2
gentoo-17a5eec31983efe168a5e157f58b59fd736fb4e7.zip
dev-util/gyp: Add support for Python 3.8.
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-util/gyp/gyp-20200512145953.ebuild')
-rw-r--r--dev-util/gyp/gyp-20200512145953.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/dev-util/gyp/gyp-20200512145953.ebuild b/dev-util/gyp/gyp-20200512145953.ebuild
index 95e9e43a2eed..12db11a3d622 100644
--- a/dev-util/gyp/gyp-20200512145953.ebuild
+++ b/dev-util/gyp/gyp-20200512145953.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-PYTHON_COMPAT=(python{3_6,3_7})
+PYTHON_COMPAT=(python{3_6,3_7,3_8})
DISTUTILS_SINGLE_IMPL="1"
DISTUTILS_USE_SETUPTOOLS="rdepend"
@@ -31,6 +31,17 @@ BDEPEND=""
DEPEND=""
RDEPEND=""
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ sed -e "s/' Linux %s' % ' '\.join(platform.linux_distribution())/' Linux'/" -i gyptest.py || die
+ sed -e "s/the_dict_key is 'variables'/the_dict_key == 'variables'/" -i pylib/gyp/input.py || die
+ sed \
+ -e "s/os\.environ\['PRESERVE'\] is not ''/os.environ['PRESERVE'] != ''/" \
+ -e "s/conditions is ()/conditions == ()/" \
+ -i test/lib/TestCmd.py || die
+}
+
python_test() {
# More errors with DeprecationWarnings enabled.
local -x PYTHONWARNINGS=""