summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
commit398a42634f34afa1979d88ae1d8b38194e911c2d (patch)
treed6a45bdf7b35b71c192602a46e8d98d12a88cb02 /dev-util/gprof2dot
parentdev-ros/geometric_shapes: Remove old (diff)
downloadgentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.gz
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.bz2
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.zip
*/*: [QA] Remove redundant `|| die` guards
* Since all ebuilds in the tree are EAPI>=4, `|| die` on builtin commands is redundant and dead code. Closes: https://github.com/gentoo/gentoo/pull/13940 Reviewed-by: Ulrich Müller <ulm@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-util/gprof2dot')
-rw-r--r--dev-util/gprof2dot/gprof2dot-2013.05.17.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-util/gprof2dot/gprof2dot-2013.05.17.ebuild b/dev-util/gprof2dot/gprof2dot-2013.05.17.ebuild
index 0dfc78249914..b9aea7e30d80 100644
--- a/dev-util/gprof2dot/gprof2dot-2013.05.17.ebuild
+++ b/dev-util/gprof2dot/gprof2dot-2013.05.17.ebuild
@@ -36,19 +36,19 @@ _make_call_script() {
Main().main()
EOF
- fperms a+x "$1" || die
+ fperms a+x "$1"
}
src_install() {
abi_specific_install() {
local sitedir="$(python_get_sitedir)"
insinto ${sitedir#"${EPREFIX}"}
- doins ${PN}.py || die
+ doins ${PN}.py
python_optimize || die
}
python_foreach_impl abi_specific_install
- dodir /usr/bin || die
+ dodir /usr/bin
_make_call_script /usr/bin/${PN} || die
python_replicate_script "${ED}"/usr/bin/${PN} || die
}