summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/geany
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/geany')
-rw-r--r--dev-util/geany/Manifest3
-rw-r--r--dev-util/geany/geany-1.23.1.ebuild61
-rw-r--r--dev-util/geany/geany-1.24.1.ebuild62
-rw-r--r--dev-util/geany/geany-1.25.ebuild63
-rw-r--r--dev-util/geany/metadata.xml41
5 files changed, 230 insertions, 0 deletions
diff --git a/dev-util/geany/Manifest b/dev-util/geany/Manifest
new file mode 100644
index 000000000000..ce4d56889987
--- /dev/null
+++ b/dev-util/geany/Manifest
@@ -0,0 +1,3 @@
+DIST geany-1.23.1.tar.bz2 3622524 SHA256 8815b16e59d8679ec359a1a5754fee05e77f7bca53083c939654bfc77d978fad SHA512 e986c35b5fbbc23745d3acda4cddc5de6f273807ffb4da7ff7ea20f108c1f04d763b1207268f06bc45e675d0f0883b309a90dc8e27b8af2f1ec626b557faf015 WHIRLPOOL d777c915738338de7d67578527c63b9da201eefd3322c2118513082b1f109187f6a4900c6ed335e4bd6b2d6472d34ecaff6d1267f43b38827b73026c813e2108
+DIST geany-1.24.1.tar.bz2 3990492 SHA256 7fb505d9b01fe6874890525f837644a6a38c23a372bb068c65ef3673108a8c33 SHA512 89bf627a861dd4c1087f283c71da9ba9c978f00f3106d97a8ee118c5b1134a8dabc0794a06fb85e58e17689e4d38da4814251b62f4109eb99984fa866483d716 WHIRLPOOL c9c7bfac0130a9e88c22136c5caf19c2965a1707f667a29e20d1aedb626f843ff93fc147b6afdcd1108842bc93e9facf19257a3290aa96c09429af93a5bf4aa7
+DIST geany-1.25.tar.bz2 4149876 SHA256 8ee41da28cead8c94d433e616d7ababa81727c63e9196ca6758ade3af14a49ef SHA512 18c98190e387870fd85e8dba7c8033be90594bad038701cc285bfa6a7c3e8bf2817b91330be8d832c18afa3aba17bb3c9c67d86921c5c55be21483b0eb727942 WHIRLPOOL 3f94b5a87b22bc4c45f5f5eccf8d2cb6a1419fe7598e6e2414eb6ea1c08ea7e35bf28b8e1115da3249e58a2136fae7c82ff2f56dbf416a97df3a55b66133ced6
diff --git a/dev-util/geany/geany-1.23.1.ebuild b/dev-util/geany/geany-1.23.1.ebuild
new file mode 100644
index 000000000000..5d8a02fcb634
--- /dev/null
+++ b/dev-util/geany/geany-1.23.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils fdo-mime gnome2-utils
+
+LANGS="ar ast be bg ca cs de el en_GB es et eu fa fi fr gl he hi hu id it ja kk ko lb lt mn nl nn pl pt pt_BR ro ru sk sl sr sv tr uk vi zh_CN ZH_TW"
+NOSHORTLANGS="en_GB zh_CN zh_TW"
+
+DESCRIPTION="GTK+ based fast and lightweight IDE"
+HOMEPAGE="http://www.geany.org"
+SRC_URI="http://download.geany.org/${P}.tar.bz2"
+
+LICENSE="GPL-2+ HPND"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="+vte"
+
+RDEPEND=">=x11-libs/gtk+-2.16:2
+ >=dev-libs/glib-2.20:2
+ vte? ( x11-libs/vte:0 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext"
+
+pkg_setup() {
+ strip-linguas ${LANGS}
+}
+
+src_prepare() {
+ # Syntax highlighting for Portage
+ sed -i -e "s:*.sh;:*.sh;*.ebuild;*.eclass;:" \
+ data/filetype_extensions.conf || die
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --docdir="/usr/share/doc/${PF}" \
+ $(use_enable vte)
+}
+
+src_install() {
+ emake DESTDIR="${D}" DOCDIR="${ED}/usr/share/doc/${PF}" install
+ rm -f "${ED}"/usr/share/doc/${PF}/{COPYING,GPL-2,ScintillaLicense.txt}
+ prune_libtool_files --all
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
diff --git a/dev-util/geany/geany-1.24.1.ebuild b/dev-util/geany/geany-1.24.1.ebuild
new file mode 100644
index 000000000000..24aff566d0fc
--- /dev/null
+++ b/dev-util/geany/geany-1.24.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils fdo-mime gnome2-utils
+
+LANGS="ar ast be bg ca cs de el en_GB es et eu fa fi fr gl he hi hu id it ja kk ko lb lt mn nl nn pl pt pt_BR ro ru sk sl sr sv tr uk vi zh_CN ZH_TW"
+NOSHORTLANGS="en_GB zh_CN zh_TW"
+
+DESCRIPTION="GTK+ based fast and lightweight IDE"
+HOMEPAGE="http://www.geany.org"
+SRC_URI="http://download.geany.org/${P}.tar.bz2"
+
+LICENSE="GPL-2+ HPND"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~ia64 ppc ~ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="+vte"
+
+RDEPEND=">=x11-libs/gtk+-2.16:2
+ >=dev-libs/glib-2.20:2
+ vte? ( x11-libs/vte:0 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext"
+
+pkg_setup() {
+ strip-linguas ${LANGS}
+}
+
+src_prepare() {
+ # Syntax highlighting for Portage
+ sed -i -e "s:*.sh;:*.sh;*.ebuild;*.eclass;:" \
+ data/filetype_extensions.conf || die
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --docdir="/usr/share/doc/${PF}" \
+ --disable-gtk3 \
+ $(use_enable vte)
+}
+
+src_install() {
+ emake DESTDIR="${D}" DOCDIR="${ED}/usr/share/doc/${PF}" install
+ rm -f "${ED}"/usr/share/doc/${PF}/{COPYING,GPL-2,ScintillaLicense.txt}
+ prune_libtool_files --all
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
diff --git a/dev-util/geany/geany-1.25.ebuild b/dev-util/geany/geany-1.25.ebuild
new file mode 100644
index 000000000000..9fad636508de
--- /dev/null
+++ b/dev-util/geany/geany-1.25.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils fdo-mime gnome2-utils
+
+LANGS="ar ast be bg ca cs de el en_GB es et eu fa fi fr gl he hi hu id it ja kk ko lb lt mn nl nn pl pt pt_BR ro ru sk sl sr sv tr uk vi zh_CN ZH_TW"
+NOSHORTLANGS="en_GB zh_CN zh_TW"
+
+DESCRIPTION="GTK+ based fast and lightweight IDE"
+HOMEPAGE="http://www.geany.org"
+SRC_URI="http://download.geany.org/${P}.tar.bz2"
+
+LICENSE="GPL-2+ HPND"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="gtk3 +vte"
+
+RDEPEND=">=dev-libs/glib-2.28:2
+ !gtk3? ( >=x11-libs/gtk+-2.24:2 )
+ gtk3? ( >=x11-libs/gtk+-3.0:3 )
+ vte? ( x11-libs/vte:0 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext"
+
+pkg_setup() {
+ strip-linguas ${LANGS}
+}
+
+src_prepare() {
+ # Syntax highlighting for Portage
+ sed -i -e "s:*.sh;:*.sh;*.ebuild;*.eclass;:" \
+ data/filetype_extensions.conf || die
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --docdir="/usr/share/doc/${PF}" \
+ $(use_enable gtk3) \
+ $(use_enable vte)
+}
+
+src_install() {
+ emake DESTDIR="${D}" DOCDIR="${ED}/usr/share/doc/${PF}" install
+ rm -f "${ED}"/usr/share/doc/${PF}/{COPYING,GPL-2,ScintillaLicense.txt}
+ prune_libtool_files --all
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
diff --git a/dev-util/geany/metadata.xml b/dev-util/geany/metadata.xml
new file mode 100644
index 000000000000..5989ba525e9a
--- /dev/null
+++ b/dev-util/geany/metadata.xml
@@ -0,0 +1,41 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+ </maintainer>
+ <longdescription lang="en">
+ Geany is a small and lightweight integrated development environment.
+ It was developed to provide a small and fast IDE, which has only a
+ few dependencies from other packages. Another goal was to be as
+ independent as possible from a special Desktop Environment like KDE
+ or GNOME. So it is using only the GTK2 toolkit and therefore you need
+ only the GTK2 runtime libraries to run Geany.
+
+ The basic features of Geany are: syntax highlighting; code completion;
+ auto completion of often used constructs like if, for and while;
+ auto completion of XML and HTML tags; call tips; many supported
+ filetypes like C, Java, PHP, HTML, Python, Perl, Pascal; symbol lists.
+ </longdescription>
+ <longdescription lang="fr">
+ Geany est un environnement de développement integré (EDI) petit et
+ léger. Il a été développé pour fournir un EDI petit et rapide, qui ne
+ possède que peu de dépendences avec d'autres paquets. Un autre but
+ était qu'il soit aussi indépendant que possible d'environnements de
+ bureaux comme KDE ou Gnome. Ainsi, il n'utilise que la boîte à outils
+ GTK2.
+
+ Les principales fonctionnalités sont: la coloration syntaxique; la
+ complétion de code source; la complétion automatique de certaines
+ constructions couramment utilisées, comme les blocs "if", "for" et
+ "while"; complétion automatique des balises XML et HTML; info-bulles
+ décrivant la syntaxe d'appel des fonctions; de nombreux langages
+ supportés, comme C, Java, PHP, HTML, Python, Perl, Pascal; liste des
+ symboles.
+ </longdescription>
+ <use>
+ <flag name="gtk3">Use GTK+3 instead of GTK+2</flag>
+ <flag name="vte">Enable Terminal support (<pkg>x11-libs/vte</pkg>)</flag>
+ </use>
+</pkgmetadata>