summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-09-21 21:53:37 -0400
committerMatt Turner <mattst88@gentoo.org>2023-09-21 22:32:45 -0400
commit1e1749a0436e48ae6f38abc738092bf3db038f9e (patch)
tree71b1983abf28e71fae8ab3a6c3b4748debf46124 /dev-util/gdbus-codegen
parentdev-libs/libdex: Drop old versions (diff)
downloadgentoo-1e1749a0436e48ae6f38abc738092bf3db038f9e.tar.gz
gentoo-1e1749a0436e48ae6f38abc738092bf3db038f9e.tar.bz2
gentoo-1e1749a0436e48ae6f38abc738092bf3db038f9e.zip
dev-util/gdbus-codegen: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util/gdbus-codegen')
-rw-r--r--dev-util/gdbus-codegen/Manifest1
-rw-r--r--dev-util/gdbus-codegen/gdbus-codegen-2.77.3.ebuild74
2 files changed, 0 insertions, 75 deletions
diff --git a/dev-util/gdbus-codegen/Manifest b/dev-util/gdbus-codegen/Manifest
index ca6d5eb1558a..8838499ec5d0 100644
--- a/dev-util/gdbus-codegen/Manifest
+++ b/dev-util/gdbus-codegen/Manifest
@@ -1,3 +1,2 @@
DIST glib-2.76.4.tar.xz 5274356 BLAKE2B c9ceb514ea81e1e6ab2d0efc82c48c0d8ae6c997fd0e3c56d47a5174b027f785b58266fff73b1d1132e272305126fbff22e3c65d47de46224cd12fa49796d5bc SHA512 f76932dc5090a44880373228e2b162f338415d06f7c90f2950eab1a43bb191c56a1797da4d377594f6a999197fef4defb848039259cfa4105bb68288a928f5b7
-DIST glib-2.77.3.tar.xz 5316816 BLAKE2B 94d28c1526a19cb679a85f32bda159ee07862ce6aa0e2bb2e953c748d8cc790454603d3db8c748638754fef60e74a6e3584952804ff438b49fcfc009803a07b5 SHA512 d9727d67e63d7f8ce710bff497c183799b0192ac10900da87887bd76812aad9603e7f132d7eb4e8626787c427048aeafb4a28654ab808c676bcfc2b897e005d9
DIST glib-2.78.0.tar.xz 5327096 BLAKE2B 3a494a16d12b17c7986bbe865d5e3b2727d40e7272fbb34897a90173c0fb780b0e7f024042f60ac6d1fcb9a2a4731948b6ac733c2bd6bd27c32b97281e20fc72 SHA512 3d06890002f4b13f831c83fbb70cfce529f9750e30888619e4d6277116be15d106379a03143412cf4b2a289c0cbdbbc299ecf17284fbffc06c791ecf7556c765
diff --git a/dev-util/gdbus-codegen/gdbus-codegen-2.77.3.ebuild b/dev-util/gdbus-codegen/gdbus-codegen-2.77.3.ebuild
deleted file mode 100644
index 3595e34fd897..000000000000
--- a/dev-util/gdbus-codegen/gdbus-codegen-2.77.3.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-GNOME_ORG_MODULE="glib"
-PYTHON_COMPAT=( python3_{10..12} )
-PYTHON_REQ_USE="xml(+)"
-DISTUTILS_USE_PEP517=setuptools
-DISTUTILS_SINGLE_IMPL=1
-
-inherit gnome.org distutils-r1
-
-DESCRIPTION="GDBus code and documentation generator"
-HOMEPAGE="https://www.gtk.org/"
-
-LICENSE="LGPL-2+"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-
-RDEPEND="${PYTHON_DEPS}"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-libs/libxslt
- app-text/docbook-xsl-stylesheets
-"
-
-S="${WORKDIR}/glib-${PV}/gio/gdbus-2.0/codegen"
-
-python_prepare_all() {
- PATCHES=(
- "${FILESDIR}/${PN}-2.56.1-sitedir.patch"
- )
- distutils-r1_python_prepare_all
-
- local MAJOR_VERSION=$(ver_cut 1)
- local MINOR_VERSION=$(ver_cut 2)
- sed -e 's:@PYTHON@:python:' gdbus-codegen.in > gdbus-codegen || die
- sed -e "s:@VERSION@:${PV}:" \
- -e "s:@MAJOR_VERSION@:${MAJOR_VERSION}:" \
- -e "s:@MINOR_VERSION@:${MINOR_VERSION}:" config.py.in > config.py || die
- cp "${FILESDIR}/setup.py-2.32.4" setup.py || die "cp failed"
- sed -e "s/@PV@/${PV}/" -i setup.py || die "sed setup.py failed"
-}
-
-do_xsltproc_command() {
- # Taken from meson.build for manual manpage building - keep in sync (also copied to dev-util/glib-utils)
- xsltproc \
- --nonet \
- --stringparam man.output.quietly 1 \
- --stringparam funcsynopsis.style ansi \
- --stringparam man.th.extra1.suppress 1 \
- --stringparam man.authors.section.enabled 0 \
- --stringparam man.copyright.section.enabled 0 \
- -o "${2}" \
- http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl \
- "${1}" || die "manpage generation failed"
-}
-
-src_compile() {
- distutils-r1_src_compile
- do_xsltproc_command \
- "${WORKDIR}/glib-${PV}/docs/reference/gio/gdbus-codegen.xml" \
- "${WORKDIR}/glib-${PV}/docs/reference/gio/gdbus-codegen.1"
-}
-
-src_test() {
- einfo "Skipping tests. This package is tested by dev-libs/glib"
- einfo "when merged with FEATURES=test"
-}
-
-python_install_all() {
- distutils-r1_python_install_all # no-op, but prevents QA warning
- doman "${WORKDIR}/glib-${PV}/docs/reference/gio/gdbus-codegen.1"
-}