summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-10-13 12:22:29 -0400
committerMatt Turner <mattst88@gentoo.org>2022-10-13 12:26:13 -0400
commit4b5c3deeb5c69ad03bf9fbb36da7856ede1143dc (patch)
treecf8dba6b6520f21f29ccca0eb26d0c8fd60c7174 /dev-util/d-spy
parentx11-base/xorg-fonts: Add new metapackage (diff)
downloadgentoo-4b5c3deeb5c69ad03bf9fbb36da7856ede1143dc.tar.gz
gentoo-4b5c3deeb5c69ad03bf9fbb36da7856ede1143dc.tar.bz2
gentoo-4b5c3deeb5c69ad03bf9fbb36da7856ede1143dc.zip
dev-util/d-spy: Call xdg postinst functions
Closes: https://bugs.gentoo.org/876983 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util/d-spy')
-rw-r--r--dev-util/d-spy/d-spy-1.4.0.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/dev-util/d-spy/d-spy-1.4.0.ebuild b/dev-util/d-spy/d-spy-1.4.0.ebuild
index 96b1f7360251..9beaae1b265d 100644
--- a/dev-util/d-spy/d-spy-1.4.0.ebuild
+++ b/dev-util/d-spy/d-spy-1.4.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit gnome.org meson
+inherit gnome.org meson xdg
DESCRIPTION="D-spy is a blisteringly fast D-Bus debugger"
HOMEPAGE="https://wiki.gnome.org/Apps/d-spy https://gitlab.gnome.org/GNOME/d-spy"
@@ -32,3 +32,13 @@ src_install() {
meson_src_install
mv "${ED}"/usr/share/appdata "${ED}"/usr/share/metainfo || die
}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}