summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-29 19:43:25 +0100
committerSam James <sam@gentoo.org>2022-10-29 19:43:29 +0100
commit78b9d425382db8eec78dd92aa6f4ec4de4ee4aee (patch)
tree2f6db42b944533326aaa7ad0bbd9d569b53203d0 /dev-util/coccinelle
parentapp-office/planner: add live ebuild, use meson (diff)
downloadgentoo-78b9d425382db8eec78dd92aa6f4ec4de4ee4aee.tar.gz
gentoo-78b9d425382db8eec78dd92aa6f4ec4de4ee4aee.tar.bz2
gentoo-78b9d425382db8eec78dd92aa6f4ec4de4ee4aee.zip
dev-util/coccinelle: restrict tests for now
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/coccinelle')
-rw-r--r--dev-util/coccinelle/coccinelle-1.1.1-r1.ebuild (renamed from dev-util/coccinelle/coccinelle-1.1.1.ebuild)6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-util/coccinelle/coccinelle-1.1.1.ebuild b/dev-util/coccinelle/coccinelle-1.1.1-r1.ebuild
index acf57cebffd6..a8e567e69c5b 100644
--- a/dev-util/coccinelle/coccinelle-1.1.1.ebuild
+++ b/dev-util/coccinelle/coccinelle-1.1.1-r1.ebuild
@@ -3,6 +3,7 @@
EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..11} )
inherit autotools bash-completion-r1 elisp-common python-single-r1
@@ -15,7 +16,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc emacs +ocamlopt pcre python test"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RESTRICT="strip !test? ( test )"
+# Test failures need investigation
+RESTRICT="strip !test? ( test ) test"
RDEPEND="
>=dev-lang/ocaml-3.12:=[ocamlopt?]
@@ -92,6 +94,8 @@ src_compile() {
}
src_test() {
+ # TODO: See Fedora's method?
+ # https://src.fedoraproject.org/rpms/coccinelle/blob/rawhide/f/coccinelle.spec#_231
emake VERBOSE=yes check $(usev python pycocci-check)
}