summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2024-12-02 09:53:46 +0100
committerFlorian Schmaus <flow@gentoo.org>2024-12-05 16:17:40 +0100
commit45d08b929ae0e211576ffbdde9f0af5ecc90415e (patch)
treeb431bdbbd7455372aa6aed1d2a0ac88d0ca3b517 /dev-util/bats
parentwww-apps/radicale: bump to 3.3.1 (diff)
downloadgentoo-45d08b929ae0e211576ffbdde9f0af5ecc90415e.tar.gz
gentoo-45d08b929ae0e211576ffbdde9f0af5ecc90415e.tar.bz2
gentoo-45d08b929ae0e211576ffbdde9f0af5ecc90415e.zip
dev-util/bats: bump version to 1.11.1
Signed-off-by: Henning Schild <henning@hennsch.de> Closes: https://github.com/gentoo/gentoo/pull/39553 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-util/bats')
-rw-r--r--dev-util/bats/Manifest1
-rw-r--r--dev-util/bats/bats-1.11.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-util/bats/Manifest b/dev-util/bats/Manifest
index 9b4d452bcc9b..07144077b25a 100644
--- a/dev-util/bats/Manifest
+++ b/dev-util/bats/Manifest
@@ -1 +1,2 @@
DIST bats-1.11.0.tar.gz 172044 BLAKE2B a86737e8f38e59031f926ce36e70417517095e2f34a9c6a8f1564879297dd097a44839343b66909e00338e53e8516a473e7b4bffc399166df87912e1e645809b SHA512 8f8dc767ba2d1551288942b50fdc73ef1f31e4dd1c6d7d539968454d286fff6509ed85d8728b4779d9b085e265ddf77e89a8cd8746f3afab0c7c3542eeacbd51
+DIST bats-1.11.1.tar.gz 174699 BLAKE2B 3e64257d45344a9e0a77178a77fe9f19f65aae6bb4cbba497e6ee960cb2a1d8bbcc5078b0600024f25da5c298d075c89d1fe054ee0529fb23489af05b97c1e80 SHA512 56faccadebc92555418c6aa6cb1985e7928d6db9c7bdbdd788f3dd55e82ef831d2389aa5b7198dd810fa6fd9dc6cfae78f7a10149e3027ed4f6517ede02dd8c3
diff --git a/dev-util/bats/bats-1.11.1.ebuild b/dev-util/bats/bats-1.11.1.ebuild
new file mode 100644
index 000000000000..cf782a5559be
--- /dev/null
+++ b/dev-util/bats/bats-1.11.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multiprocessing optfeature
+
+MY_PN="bats-core"
+DESCRIPTION="Bats-core: Bash Automated Testing System"
+HOMEPAGE="https://github.com/bats-core/bats-core/"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+DEPEND="app-shells/bash:*"
+RDEPEND="${DEPEND}"
+
+src_test() {
+ local my_jobs=$(get_nproc)
+ if ! command -v parallel >/dev/null; then
+ my_jobs=1
+ fi
+ bin/bats --tap --jobs "${my_jobs}" test || die "Tests failed"
+}
+
+src_install() {
+ exeinto /usr/libexec/${MY_PN}
+ doexe libexec/${MY_PN}/*
+ exeinto /usr/lib/${MY_PN}
+ doexe lib/${MY_PN}/*
+ dobin bin/${PN}
+
+ dodoc README.md
+ doman man/${PN}.1 man/${PN}.7
+}
+
+pkg_postinst() {
+ optfeature "Parallel Execution" sys-process/parallel
+}