summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/babeltrace
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/babeltrace')
-rw-r--r--dev-util/babeltrace/Manifest2
-rw-r--r--dev-util/babeltrace/babeltrace-1.2.3.ebuild33
-rw-r--r--dev-util/babeltrace/babeltrace-1.2.4.ebuild33
-rw-r--r--dev-util/babeltrace/metadata.xml11
4 files changed, 79 insertions, 0 deletions
diff --git a/dev-util/babeltrace/Manifest b/dev-util/babeltrace/Manifest
new file mode 100644
index 000000000000..50eac23572a7
--- /dev/null
+++ b/dev-util/babeltrace/Manifest
@@ -0,0 +1,2 @@
+DIST babeltrace-1.2.3.tar.bz2 995094 SHA256 796fa6978102244d9c64d474baeac4e4292a0186660a53cf58f20d47226987ac SHA512 de231c9e25797d0f3cfb8692fc75b8ce4159d317bb861806955f098a99d5749b627c830111d37788d0da486fdef92c83c020588a6598b4e95bcff6cbf9fce77f WHIRLPOOL c473821bc5648865d5460c9b55d8e59cb6416057f7e43d6d8a81950ce62310309cc1dc23845cc7b16ba3533d6f28d0c2352a2f304163bf378725ac10c5831e86
+DIST babeltrace-1.2.4.tar.bz2 995829 SHA256 666e3a1ad2dc7d5703059963056e7800f0eab59c8eeb6be2efe4f3acc5209eb1 SHA512 5cfd4572519ec53ad531d333ac5e1df026ebd1a200e0fbec59c892cad5273316e07482a4199a1cb2dcb4994310b04b259748de169c4a7c1ddafd7e185f32c5f9 WHIRLPOOL 31c5a65c7dea2318d1938e6163a6650ca0bab47579389c44c35caa47d7d7f6465e48c7e877450f200690da277e1aace4097eef90bb72dc66f842fa1bc2da98dc
diff --git a/dev-util/babeltrace/babeltrace-1.2.3.ebuild b/dev-util/babeltrace/babeltrace-1.2.3.ebuild
new file mode 100644
index 000000000000..19b8315b2c52
--- /dev/null
+++ b/dev-util/babeltrace/babeltrace-1.2.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A command-line tool and library to read and convert trace files"
+HOMEPAGE="http://lttng.org"
+SRC_URI="http://lttng.org/files/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/popt
+ sys-apps/util-linux
+ "
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ "
+src_configure() {
+ econf $(use_enable test glibtest)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/dev-util/babeltrace/babeltrace-1.2.4.ebuild b/dev-util/babeltrace/babeltrace-1.2.4.ebuild
new file mode 100644
index 000000000000..19b8315b2c52
--- /dev/null
+++ b/dev-util/babeltrace/babeltrace-1.2.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A command-line tool and library to read and convert trace files"
+HOMEPAGE="http://lttng.org"
+SRC_URI="http://lttng.org/files/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/popt
+ sys-apps/util-linux
+ "
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ "
+src_configure() {
+ econf $(use_enable test glibtest)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/dev-util/babeltrace/metadata.xml b/dev-util/babeltrace/metadata.xml
new file mode 100644
index 000000000000..0968da43259a
--- /dev/null
+++ b/dev-util/babeltrace/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>dlan@gentoo.org</email>
+ <name>Yixun Lan</name>
+ </maintainer>
+ <longdescription>
+ Babeltrace is a command-line tool and library to read and convert trace files to and from different formats. It supports the CTF format, which is outputted by the LTTng 2.0 tracers.
+ </longdescription>
+</pkgmetadata>