summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-20 01:17:17 +0100
committerSam James <sam@gentoo.org>2023-10-20 01:50:57 +0100
commitfc74cec9629ff0ed4a84f125364cacbc5aff61ed (patch)
treed316a3103bc9247df987f9866524fbb8b67dc412 /dev-util/astyle
parentapp-text/highlight: add 4.9 (diff)
downloadgentoo-fc74cec9629ff0ed4a84f125364cacbc5aff61ed.tar.gz
gentoo-fc74cec9629ff0ed4a84f125364cacbc5aff61ed.tar.bz2
gentoo-fc74cec9629ff0ed4a84f125364cacbc5aff61ed.zip
dev-util/astyle: add 3.4.9
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/astyle')
-rw-r--r--dev-util/astyle/Manifest2
-rw-r--r--dev-util/astyle/astyle-3.4.9.ebuild83
2 files changed, 85 insertions, 0 deletions
diff --git a/dev-util/astyle/Manifest b/dev-util/astyle/Manifest
index 15bcc718d663..859fef9e3ae1 100644
--- a/dev-util/astyle/Manifest
+++ b/dev-util/astyle/Manifest
@@ -1,3 +1,5 @@
DIST astyle-3.4.8.tar.bz2 229679 BLAKE2B 413204c5f53276ff533300bcb86c8c8ef8cf91371b2ac70431957dee1e713acd64eee6da18e2919ab51ca6757b30363997eeb2baae621a8cb302011adfc80c97 SHA512 8c0c79eea04ecdbc24f6e673a1a848d8682dc4e4f83949887eca5be98d5c485298fb44b0e9c70444c41ed09eb62662335138058bcfc9d3de21978149bc1b6ddc
DIST astyle-3.4.8.tar.bz2.asc 488 BLAKE2B cb3aada25bb5f6f9c433bdc0a5ee6464ff2266f38a0b0a847349b4d56e7fed5ff055e296a0502c77d7f120aeaf3c7cfbd898850b455f927218cf8a66406e1ce7 SHA512 29085bf168435072c98ea4238798e7123e8ca9595b1a036a1d91dee128718d9c500d010be4cd0f6f7039abffce8341728ba1cdb01b7a06d77500c1e6b0cab873
+DIST astyle-3.4.9.tar.bz2 229873 BLAKE2B f698ec0f3447caf64f324760f9d9feabeb9588f603fb1bfd60b5272cc12525e8c942c084b325f7be1bfe93663de360727ddf8bdc65d38c84512852106cb2f70b SHA512 6538e1e9464564819bd1d8eef041de063a74e8974d2cc5942046a03fa70bd5472c20438bfd270dcf1f00d250d961129ce53b5ad18646505837e176c4e0e3f00a
+DIST astyle-3.4.9.tar.bz2.asc 488 BLAKE2B a5ed720e7c87f3603ba514e0fd15fb3a6687d913ec6cb41323aa5b1b38e76ac4ece310307ad23f8ba4c5d3e7b0cc00b78684d0c219fc50cd9e5db9c327c4f04b SHA512 b9f18e2c20b431b98859b996c52b31edbd9368d3a7ada1324f3139984f5480af860981f3b72802f548f2a73e53232f35fc2256a8a3eb7cc6a31685921682d9e4
DIST astyle_3.1_linux.tar.gz 185589 BLAKE2B d0bc9bf3403de89d207f33ac885c7cd57fd1e71314c947e1593ee24ade9ce36c83c6fd8e7021f44d8d3b344ea3add63fa5a7b246c40f10193dc38b51e7ad36bc SHA512 2e8f13d291abda66bbba30174c364c81a81a490e0a21376f7da7cf471644c22caa37b9eefb100d093bf26d1a8bfa9d2f14b4c2a9b75b3cb84428b4514e277ff2
diff --git a/dev-util/astyle/astyle-3.4.9.ebuild b/dev-util/astyle/astyle-3.4.9.ebuild
new file mode 100644
index 000000000000..126f56e4b4a4
--- /dev/null
+++ b/dev-util/astyle/astyle-3.4.9.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/andresimon.asc
+inherit toolchain-funcs java-pkg-opt-2 verify-sig
+
+DESCRIPTION="Artistic Style is a re-indenter and reformatter for C++, C and Java source code"
+HOMEPAGE="https://astyle.sourceforge.net/ https://gitlab.com/saalen/astyle"
+SRC_URI="
+ mirror://sourceforge/astyle/${P}.tar.bz2
+ http://www.andre-simon.de/zip/${P}.tar.bz2
+ verify-sig? ( http://www.andre-simon.de/zip/${P}.tar.bz2.asc )
+"
+
+LICENSE="MIT"
+SLOT="0/3.2"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="examples java static-libs"
+
+DEPEND="
+ app-arch/xz-utils
+ java? ( >=virtual/jdk-1.6:= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="verify-sig? ( sec-keys/openpgp-keys-andresimon )"
+
+src_prepare() {
+ if use java ; then
+ java-pkg-opt-2_src_prepare
+ sed -e "s:^\(JAVAINCS\s*\)=.*$:\1= $(java-pkg_get-jni-cflags):" \
+ -e "s:ar crs:$(tc-getAR) crs:" \
+ -i build/gcc/Makefile || die
+ else
+ default
+ fi
+}
+
+src_configure() {
+ tc-export CXX
+ default
+}
+
+src_compile() {
+ # ../build/clang/Makefile is identical except for CXX line.
+ emake CXX="$(tc-getCXX)" -f ../build/gcc/Makefile -C src \
+ ${PN} \
+ shared \
+ $(usev java) \
+ $(usev static-libs static)
+}
+
+src_install() {
+ doheader src/${PN}.h
+
+ pushd src/bin >/dev/null || die
+ dobin ${PN}
+
+ local libastylename="lib${PN}.so.${SLOT##*/}.0"
+ local libastylejname="lib${PN}j.so.${SLOT##*/}.0"
+ local libdestdir="/usr/$(get_libdir)"
+
+ dolib.so "${libastylename}"
+ dosym "${libastylename}" "${libdestdir}/lib${PN}.so.$(ver_cut 1 ${SLOT##*/})"
+ dosym "${libastylename}" "${libdestdir}/lib${PN}.so"
+ if use java ; then
+ dolib.so "${libastylejname}"
+ dosym "${libastylejname}" "${libdestdir}/lib${PN}j.so.$(ver_cut 1 ${SLOT##*/})"
+ dosym "${libastylejname}" "${libdestdir}/lib${PN}j.so"
+ fi
+ if use static-libs ; then
+ dolib.a lib${PN}.a
+ fi
+ popd >/dev/null || die
+ if use examples ; then
+ docinto examples
+ dodoc -r file/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ local HTML_DOCS=( doc/. )
+ einstalldocs
+}