summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-12-20 12:08:45 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-12-20 12:31:19 +0100
commit227c0303cb5e66ba544bd7291bd95f05bd9e18a3 (patch)
treec4188c1fafabd2eb3d9c62ae6d697d3ac769fc83 /dev-util/0xtools
parentdev-lang/eisl: bump to 5.39 (diff)
downloadgentoo-227c0303cb5e66ba544bd7291bd95f05bd9e18a3.tar.gz
gentoo-227c0303cb5e66ba544bd7291bd95f05bd9e18a3.tar.bz2
gentoo-227c0303cb5e66ba544bd7291bd95f05bd9e18a3.zip
dev-util/0xtools: add OpenRC xcapture init script
Closes: https://bugs.gentoo.org/939915 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-util/0xtools')
-rw-r--r--dev-util/0xtools/0xtools-2.0.3-r3.ebuild (renamed from dev-util/0xtools/0xtools-2.0.3-r2.ebuild)1
-rw-r--r--dev-util/0xtools/0xtools-9999.ebuild1
-rw-r--r--dev-util/0xtools/files/0xtools-2.0.3-xcapture-r0.initd34
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/0xtools/0xtools-2.0.3-r2.ebuild b/dev-util/0xtools/0xtools-2.0.3-r3.ebuild
index e6903af81533..9824d4e91272 100644
--- a/dev-util/0xtools/0xtools-2.0.3-r2.ebuild
+++ b/dev-util/0xtools/0xtools-2.0.3-r3.ebuild
@@ -65,6 +65,7 @@ src_install() {
systemd_dounit xcapture.service
systemd_dounit xcapture-restart.service
systemd_dounit xcapture-restart.timer
+ newinitd "${FILESDIR}/0xtools-2.0.3-xcapture-r0.initd" xcapture
# Setup for "xcapture-bpf".
exeinto "/lib/${PN}/xcapture"
diff --git a/dev-util/0xtools/0xtools-9999.ebuild b/dev-util/0xtools/0xtools-9999.ebuild
index 395a7ccf798a..581161fc5dab 100644
--- a/dev-util/0xtools/0xtools-9999.ebuild
+++ b/dev-util/0xtools/0xtools-9999.ebuild
@@ -65,6 +65,7 @@ src_install() {
systemd_dounit xcapture.service
systemd_dounit xcapture-restart.service
systemd_dounit xcapture-restart.timer
+ newinitd "${FILESDIR}/0xtools-2.0.3-xcapture-r0.initd" xcapture
# Setup for "xcapture-bpf".
exeinto "/lib/${PN}/xcapture"
diff --git a/dev-util/0xtools/files/0xtools-2.0.3-xcapture-r0.initd b/dev-util/0xtools/files/0xtools-2.0.3-xcapture-r0.initd
new file mode 100644
index 000000000000..0a7d427b6b19
--- /dev/null
+++ b/dev-util/0xtools/files/0xtools-2.0.3-xcapture-r0.initd
@@ -0,0 +1,34 @@
+#!/sbin/openrc-run
+
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+description="0x.Tools xcapture"
+
+SAMPLEINTERVAL="1"
+LOGDIRPATH="/var/log/xcapture"
+ADDITIONALOPTIONS="syscall,wchan,exe,cmdline"
+MINUTES="59520"
+
+config_file="/etc/default/xcapture"
+
+if [ -f "${config_file}" ] ; then
+ . "${config_file}"
+fi
+
+command="/usr/bin/xcapture"
+command_args="-d ${SAMPLEINTERVAL} -c ${ADDITIONALOPTIONS} -o ${LOGDIRPATH}"
+
+command_background="true"
+pidfile="/run/xcapture.pid"
+
+command_user="root"
+
+depend() {
+ config "${config_file}"
+ after bootmisc
+}
+
+start_pre() {
+ checkpath -q -d "${LOGDIRPATH}"
+}