summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-11-09 17:20:51 -0500
committerAaron Bauman <bman@gentoo.org>2019-11-09 17:21:20 -0500
commit31ba5252bf6bf80a33d55c5d692801a26b970db7 (patch)
tree4e19e69ae16dd0a833428ea9f5fd43730ba81ddb /dev-tex
parentpackage.mask: Last rite sys-cluster/{cman-lib,dlm,dlm-lib} (diff)
downloadgentoo-31ba5252bf6bf80a33d55c5d692801a26b970db7.tar.gz
gentoo-31ba5252bf6bf80a33d55c5d692801a26b970db7.tar.bz2
gentoo-31ba5252bf6bf80a33d55c5d692801a26b970db7.zip
dev-tex/currvita: bump EAPI and stuff
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/currvita/currvita-0.9i-r1.ebuild25
1 files changed, 13 insertions, 12 deletions
diff --git a/dev-tex/currvita/currvita-0.9i-r1.ebuild b/dev-tex/currvita/currvita-0.9i-r1.ebuild
index 3e4bb3afa652..bbec7ac34cdb 100644
--- a/dev-tex/currvita/currvita-0.9i-r1.ebuild
+++ b/dev-tex/currvita/currvita-0.9i-r1.ebuild
@@ -1,33 +1,34 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
inherit latex-package
DESCRIPTION="A LaTeX package for typesetting a curriculum vitae"
-HOMEPAGE="http://www.ctan.org/tex-archive/macros/latex/contrib/currvita/"
+HOMEPAGE="https://www.ctan.org/tex-archive/macros/latex/contrib/currvita/"
# snapshot taken from
# ftp://ftp.dante.de/tex-archive/macros/latex/contrib/currvita.tar.gz
SRC_URI="mirror://gentoo/${P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+LICENSE="GPL-2"
+SLOT="0"
IUSE=""
DEPEND="dev-texlive/texlive-langgerman"
RDEPEND="${DEPEND}"
-S="${WORKDIR}/${PN}"
-
TEXMF="/usr/share/texmf-site"
-DOCS="README"
+
+DOCS=( "README" )
+
+S="${WORKDIR}/${PN}"
src_test() {
- latex currvita.dtx || die "first step of currvita.dtx failed"
- latex currvita.dtx || die "second step of currvita.dtx failed"
- latex currvita.dtx || die "third step of currvita.dtx failed"
- latex cvtest.tex || die "processing cvtest.tex failed"
+ latex currvita.dtx || die "first test of currvita.dtx failed"
+ latex currvita.dtx || die "second test of currvita.dtx failed"
+ latex currvita.dtx || die "third test of currvita.dtx failed"
+ latex cvtest.tex || die "test of cvtest.tex failed"
}