summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tex/translator
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tex/translator')
-rw-r--r--dev-tex/translator/Manifest1
-rw-r--r--dev-tex/translator/metadata.xml8
-rw-r--r--dev-tex/translator/translator-1.00.ebuild27
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-tex/translator/Manifest b/dev-tex/translator/Manifest
new file mode 100644
index 000000000000..e4b09ed01ec5
--- /dev/null
+++ b/dev-tex/translator/Manifest
@@ -0,0 +1 @@
+DIST translator-1.00.tar.gz 178794 SHA256 08e14042fdca9381da777729ab0dde32b6f3b70479daf00152044fe1b5bd40fa SHA512 045b09ef303fe8f7bbbbc3f6b4175da4ba0d72d1d359281fbd316ef32eb369c627f708a19a5bade1abb4d0bc6a6320f081ccead1173665c483ce882b44013038 WHIRLPOOL 66332df456f97a25e7f9037100325e0a5c6140534a5dec2b8e5ef1bee631d6cfd96ce39fd8deff22f51fa2fd4004985ce945fb17cbf2387cb37b388f7d8e0ad9
diff --git a/dev-tex/translator/metadata.xml b/dev-tex/translator/metadata.xml
new file mode 100644
index 000000000000..f9f92d934281
--- /dev/null
+++ b/dev-tex/translator/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tex</herd>
+ <upstream>
+ <remote-id type="sourceforge">latex-beamer</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-tex/translator/translator-1.00.ebuild b/dev-tex/translator/translator-1.00.ebuild
new file mode 100644
index 000000000000..ecb51a79ba78
--- /dev/null
+++ b/dev-tex/translator/translator-1.00.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit latex-package
+
+DESCRIPTION="A package for translating words in TeX"
+HOMEPAGE="http://latex-beamer.sourceforge.net/"
+SRC_URI="mirror://sourceforge/latex-beamer/${P}.tar.gz"
+
+LICENSE="GPL-2 LPPL-1.3c"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="doc"
+
+TEXMF="/usr/share/texmf-site"
+
+src_install() {
+ insinto ${TEXMF}/tex/latex/${PN}
+ doins base/* || die "Failed to install the package"
+ doins -r dicts/* || die "Failed to install dictonaries"
+ dodoc ChangeLog README || die "dodoc failed"
+ if use doc ; then
+ insinto /usr/share/doc/${PF}
+ doins -r doc/* || die "Failed to install documentation"
+ fi
+}