summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-11-09 18:00:56 -0500
committerAaron Bauman <bman@gentoo.org>2019-11-09 18:01:14 -0500
commit4bfc4c67407892b960b16c5ba4ef901c7a3260f6 (patch)
treecac1da865381f65272b1862b4b9be59210483331 /dev-tex/tipa/tipa-1.3.ebuild
parentdev-libs/libpcre2-10.33-r1: alpha stable, bug 699052 (diff)
downloadgentoo-4bfc4c67407892b960b16c5ba4ef901c7a3260f6.tar.gz
gentoo-4bfc4c67407892b960b16c5ba4ef901c7a3260f6.tar.bz2
gentoo-4bfc4c67407892b960b16c5ba4ef901c7a3260f6.zip
dev-tex/tipa: bump EAPI and stuff
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-tex/tipa/tipa-1.3.ebuild')
-rw-r--r--dev-tex/tipa/tipa-1.3.ebuild27
1 files changed, 13 insertions, 14 deletions
diff --git a/dev-tex/tipa/tipa-1.3.ebuild b/dev-tex/tipa/tipa-1.3.ebuild
index 6d68b16c4c99..02b80da63266 100644
--- a/dev-tex/tipa/tipa-1.3.ebuild
+++ b/dev-tex/tipa/tipa-1.3.ebuild
@@ -1,40 +1,39 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
DESCRIPTION="International Phonetic Alphabet package for LaTeX"
-HOMEPAGE="http://www.l.u-tokyo.ac.jp/~fkr/"
-SRC_URI="http://www.l.u-tokyo.ac.jp/~fkr/tipa/${P}.tar.gz"
+HOMEPAGE="https://www.l.u-tokyo.ac.jp/~fkr/"
+SRC_URI="https://www.l.u-tokyo.ac.jp/~fkr/tipa/${P}.tar.gz"
-LICENSE="LPPL-1.2"
-SLOT="0"
KEYWORDS="amd64 x86"
+LICENSE="LPPL-1.2"
+SLOT="0"
IUSE=""
DEPEND="virtual/latex-base"
RDEPEND="${DEPEND}"
-src_compile() {
+src_prepare() {
# install files under /usr/share/texmf/
sed -e 's@PREFIX=/usr/local/teTeX/share/texmf@PREFIX=/usr/share/texmf@' \
- -i Makefile || die "sed failed"
+ -i Makefile || die "sed #1 failed"
sed -e 's/\($(TEXDIR)\)/$(DESTDIR)\/\1/' \
-e 's/\($(FONTDIR)\)/$(DESTDIR)\/\1/g' \
-e 's/\($(MAPDIR)\)/$(DESTDIR)\/\1/' \
- -i Makefile || die "sed failed"
+ -i Makefile || die "sed #2 failed"
# removing `mktexlsr` from Makefile (leads to access violation)
- sed -e 's/-mktexlsr//' -i Makefile || die "sed failed"
+ sed -e 's/-mktexlsr//' -i Makefile || die "sed #3 failed"
+ default
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed."
- dodoc doc/*.{tex,sty,bib,bbl} || die "dodoc failed."
-
- elog "A huge documentation can be found in '/usr/share/doc/${P}'."
+ emake DESTDIR="${D}" install
+ dodoc doc/*.{tex,sty,bib,bbl}
}
pkg_postinst() {