summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tex/svninfo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tex/svninfo')
-rw-r--r--dev-tex/svninfo/Manifest1
-rw-r--r--dev-tex/svninfo/files/svninfo-0.5-latex-compile.patch11
-rw-r--r--dev-tex/svninfo/metadata.xml5
-rw-r--r--dev-tex/svninfo/svninfo-0.7.4.ebuild28
4 files changed, 45 insertions, 0 deletions
diff --git a/dev-tex/svninfo/Manifest b/dev-tex/svninfo/Manifest
new file mode 100644
index 000000000000..d4cde8e6f4ab
--- /dev/null
+++ b/dev-tex/svninfo/Manifest
@@ -0,0 +1 @@
+DIST svninfo-0.7.4.tar.gz 14666 SHA256 aa4cec5058211e2841ad1850fc0f2394ca6806603d4190be95c0bfad4d15f698 SHA512 453874d185fba9bacda7f3454ea942b378fa3797e66204c5a26e78ad33b472dfcfdb874d864f534f7f5c49ca67becf029811b5677fb310525505362419dfb51c WHIRLPOOL 2b6a3758369da881f2f8b02a8731eb0bfe846be9587ad849f7e68abb8a45622fa29ee866963057e42e6e20cddea02195ffa1cd216d92546b102535cd5d269ed7
diff --git a/dev-tex/svninfo/files/svninfo-0.5-latex-compile.patch b/dev-tex/svninfo/files/svninfo-0.5-latex-compile.patch
new file mode 100644
index 000000000000..201256fc6536
--- /dev/null
+++ b/dev-tex/svninfo/files/svninfo-0.5-latex-compile.patch
@@ -0,0 +1,11 @@
+--- svninfo/Makefile.old 2006-02-11 23:57:52.000000000 +0100
++++ svninfo/Makefile 2006-02-11 23:58:10.000000000 +0100
+@@ -74,7 +74,7 @@
+ $(PDFLATEX) $*.tex
+
+ %.ps:%.dvi
+- $(DVIPS) $*.dvi
++ $(DVIPS) -o $@ $<
+
+ html: svninfo.perl svninfo2html.tex
+ rm -fr $(HTML_DIR)
diff --git a/dev-tex/svninfo/metadata.xml b/dev-tex/svninfo/metadata.xml
new file mode 100644
index 000000000000..ba6a8a8800d5
--- /dev/null
+++ b/dev-tex/svninfo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>tex</herd>
+</pkgmetadata>
diff --git a/dev-tex/svninfo/svninfo-0.7.4.ebuild b/dev-tex/svninfo/svninfo-0.7.4.ebuild
new file mode 100644
index 000000000000..369f28086b40
--- /dev/null
+++ b/dev-tex/svninfo/svninfo-0.7.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit latex-package eutils
+
+LICENSE="LPPL-1.2"
+DESCRIPTION="A LaTeX module to access SVN version info"
+HOMEPAGE="http://www.brucker.ch/projects/svninfo/index.en.html"
+SRC_URI="http://www.brucker.ch/projects/svninfo/download/${P}.tar.gz"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+DOCS="README"
+
+TEXMF=/usr/share/texmf-site
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-0.5-latex-compile.patch"
+}
+
+src_compile() {
+ export VARTEXFONTS="${T}/fonts"
+ emake -j1 || die "compilation failed"
+}