summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tex/slatex
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tex/slatex')
-rw-r--r--dev-tex/slatex/Manifest1
-rw-r--r--dev-tex/slatex/metadata.xml12
-rw-r--r--dev-tex/slatex/slatex-20090928.ebuild43
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-tex/slatex/Manifest b/dev-tex/slatex/Manifest
new file mode 100644
index 000000000000..7962682eb158
--- /dev/null
+++ b/dev-tex/slatex/Manifest
@@ -0,0 +1 @@
+DIST slatex-20090928.tar.bz2 47891 SHA256 6d65765d7a88b8859342bfcc9ae59779fab7afaa4ee8e4f59d22ebd8a6a3885b SHA512 4b289ba86d4e157319436d55cf7951dc5493c40bf3901fe16b879db68a234bfbd71d6dc21b18f43d77a637c973df126709a8e63086507af6ae3b2f3dc712abb1 WHIRLPOOL f9a1f1c0ee3b36ef5f608fb0f844071abe943e12e3ef0504746f8bd9100ed050bd4b73110f30d713b228adb89b40d43319bb9a178e5b3ceeb432b1fc82e4a9a3
diff --git a/dev-tex/slatex/metadata.xml b/dev-tex/slatex/metadata.xml
new file mode 100644
index 000000000000..40280b1e69ce
--- /dev/null
+++ b/dev-tex/slatex/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>scheme</herd>
+ <maintainer>
+ <email>hkBst@gentoo.org</email>
+ <name>Marijn Schouten</name>
+ </maintainer>
+ <longdescription lang="en">
+SLaTeX is a Scheme program that allows you to write programs or program fragments ``as is'' in your TeX or LaTeX source. It is particularly geared to the programming languages Scheme and other Lisps, eg, Common Lisp. The formatting of the code includes assigning appropriate fonts and colors to the various tokens in the code (keywords, variables, constants, data), at the same time retaining the proper indentation when going to the non-monospace (non-typewriter) fonts provided by TeX. SLaTeX comes with two databases that recognize the identifier conventions of Scheme and Common Lisp respectively. These can be modified by the user with easy TeX commands. In addition, the user can tell SLaTeX to typeset certain identifiers as specially suited TeX expressions (ie, beyond just fonting them). All this is done without interfering with the identifier conventions of the language of the programming code. In sum, no change need be made to your (presumably running) program code in order to get a typeset version with a desired look: You can get a spectrum of styles ranging from no fonting through basic default fonting to various ``mathematical''-looking output for pedagogic or other reasons.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-tex/slatex/slatex-20090928.ebuild b/dev-tex/slatex/slatex-20090928.ebuild
new file mode 100644
index 000000000000..ed0523ae7779
--- /dev/null
+++ b/dev-tex/slatex/slatex-20090928.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+# for updating the texmf database, id est latex-package_rehash
+inherit latex-package
+
+DESCRIPTION="SLaTeX is a Scheme program that allows you to write Scheme code in your (La)TeX source"
+HOMEPAGE="http://www.ccs.neu.edu/home/dorai/slatex/slatxdoc.html"
+SRC_URI="http://evalwhen.com/slatex/slatex.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="freedist" # license doesn't grant the right for modifications
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="dev-scheme/guile"
+DEPEND="${CDEPEND} dev-scheme/scmxlate !dev-scheme/plt-scheme"
+RDEPEND="${CDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+TARGET_DIR="/usr/share/${PN}"
+
+src_prepare() {
+ sed "s:\"/home/dorai/.www/slatex/slatex.scm\":\"${TARGET_DIR}/slatex.scm\":" \
+ -i scmxlate-slatex-src.scm || die "sed failed"
+}
+
+src_compile() {
+ local command="(load \"/usr/share/scmxlate/scmxlate.scm\")"
+ guile -c "${command}" <<< "guile" || die
+}
+
+src_install() {
+ insinto "${TARGET_DIR}"
+ doins ${PN}.scm || die "doins failed"
+ insinto /usr/share/texmf/tex/latex/slatex/
+ doins ${PN}.sty || die "doins failed"
+ dobin ${PN} || die "dobin failed"
+}