summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tex/sketch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tex/sketch')
-rw-r--r--dev-tex/sketch/Manifest1
-rw-r--r--dev-tex/sketch/metadata.xml14
-rw-r--r--dev-tex/sketch/sketch-0.3.7.ebuild44
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-tex/sketch/Manifest b/dev-tex/sketch/Manifest
new file mode 100644
index 000000000000..43bb088835ee
--- /dev/null
+++ b/dev-tex/sketch/Manifest
@@ -0,0 +1 @@
+DIST sketch-0.3.7.tgz 2882384 SHA256 12962ad5fe5a0f7c9fc6d84bd4d09b879bbf604975c839405f1613be657ba804 SHA512 efa827ab2427177ea83dd153f1f99c8e8eb339220b5edd68bfb3854d2280287158967e8b024cf0ebd92b18627183efba34693e84cec4431de0f323fe468342d3 WHIRLPOOL 693fb5c3e54f3c152ef9be9d86a6027443bb35ed8e67a3d3641ffd1ef41dc41479530fc53ccc2671145515057bf6824daf794c64318fb22a15a2ff500ea696b0
diff --git a/dev-tex/sketch/metadata.xml b/dev-tex/sketch/metadata.xml
new file mode 100644
index 000000000000..cf72776fa56a
--- /dev/null
+++ b/dev-tex/sketch/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>tex</herd>
+<herd>proxy-maintainers</herd>
+<maintainer>
+ <email>aballier@gentoo.org</email>
+ <name>Alexis Ballier</name>
+</maintainer>
+<maintainer>
+ <email>dima@sphinx.net.ru</email>
+ <name>Dmitry Dzhus</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-tex/sketch/sketch-0.3.7.ebuild b/dev-tex/sketch/sketch-0.3.7.ebuild
new file mode 100644
index 000000000000..7f6c48c22ae0
--- /dev/null
+++ b/dev-tex/sketch/sketch-0.3.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Produces drawings of two- or three-dimensional solid objects and scenes for TeX"
+HOMEPAGE="http://www.frontiernet.net/~eugene.ressler/"
+SRC_URI="http://www.frontiernet.net/~eugene.ressler/${P}.tgz"
+LICENSE="GPL-3"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="doc examples"
+
+DEPEND="dev-lang/perl"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ sed -i -e "s:\$(CC):\$(CC) \$(LDFLAGS):" makefile
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin sketch || die
+ edos2unix Doc/sketch.info
+ doinfo Doc/sketch.info || die
+ dohtml updates.htm || die
+ if use doc ; then
+ insinto /usr/share/doc/${PF}
+ doins Doc/sketch.pdf || die
+ dohtml Doc/sketch/* || die
+ fi
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins Data/* || die "Failed to install examples"
+ fi
+}