summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-11-08 18:25:41 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-11-08 20:34:40 +0100
commit3d3183d8cae8a29a04501351633e0bc19d7349f0 (patch)
treeb6d0fa7b0e8b0735765b3e89c8abd8e298868dd4 /dev-scheme/racket
parentapp-emacs/matlab: sync live 9999 version (diff)
downloadgentoo-3d3183d8cae8a29a04501351633e0bc19d7349f0.tar.gz
gentoo-3d3183d8cae8a29a04501351633e0bc19d7349f0.tar.bz2
gentoo-3d3183d8cae8a29a04501351633e0bc19d7349f0.zip
dev-scheme/racket: bump to 8.15
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-scheme/racket')
-rw-r--r--dev-scheme/racket/Manifest2
-rw-r--r--dev-scheme/racket/racket-8.15.ebuild199
2 files changed, 201 insertions, 0 deletions
diff --git a/dev-scheme/racket/Manifest b/dev-scheme/racket/Manifest
index 45db1c7c647e..af486ed67281 100644
--- a/dev-scheme/racket/Manifest
+++ b/dev-scheme/racket/Manifest
@@ -1,2 +1,4 @@
DIST racket-8.14-src-builtpkgs.tgz 157264256 BLAKE2B a6b5e61785abd8869db7800f5a5b5113e8462a8c887a8d1c7d9ed2af0c54ff37865d79a27a132bf9e50d0a4d2f4f58769707e9076591fdb6958c40e380df74d6 SHA512 b5eca5050aa1eab880ba0d1571c12577c80c9cd8e945caf8d07ae81864e964899f547b58e9d901444bb09575ace2c422b61fc1fc62d8c7df5b51a425b874c176
+DIST racket-8.15-src-builtpkgs.tgz 157495068 BLAKE2B eda021f0def3ca2581271a26d1ab0537bf6cc6645ee3aeb4f1bbb51e2c169b9fb10c93d34aee9794f94a1a05ccbb3f198903306438fe4af108e14a3191989c80 SHA512 17ff51fc085f8b7aaf293ae75a4fc5063e7e77a4c405eaa57b5e7b1c0e260b1219749ae45defa4f3bbae6aca8fed3836924e0a8625d1bd0c45f15db57878a194
DIST racket-minimal-8.14-src-builtpkgs.tgz 23391100 BLAKE2B 4b95b98c142d49c6f9ab5c7a654cd854183f2f088b8e8fc841ee2aaa65192ee5230634ca36caa26ffbc9bff5b1591f524ca84a4a13512249afc005998c97bd49 SHA512 f84a50be0d8a401d47d7517e6dc4b8a730b85ad80d1786edaa95b5cf86f4979e69d0f958a99de79631ed5885c4daf6092f39f1ac791f35422fe6d587e4d81465
+DIST racket-minimal-8.15-src-builtpkgs.tgz 23385589 BLAKE2B 1b55778966188d36b97e32f886562b8a8b08543b62b68d20fd3a7352c41b764386745f93915ca1edb9f785d13bac6f99618c39f7532a584fac704212c8123eb5 SHA512 2d52a0d7350f7c81b1696e657016ce93fb216419c875a3d43d41d9bc7d1d28589bb60d976e6dbd256e050ee2d8532e5f35a6fb461b5232c423fe56c9d8bf3596
diff --git a/dev-scheme/racket/racket-8.15.ebuild b/dev-scheme/racket/racket-8.15.ebuild
new file mode 100644
index 000000000000..abd4774efd67
--- /dev/null
+++ b/dev-scheme/racket/racket-8.15.ebuild
@@ -0,0 +1,199 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit check-reqs desktop optfeature toolchain-funcs readme.gentoo-r1
+
+DESCRIPTION="General purpose, multi-paradigm Lisp-Scheme programming language"
+HOMEPAGE="https://racket-lang.org/
+ https://github.com/racket/racket/"
+
+SRC_URI="
+ minimal? ( https://download.racket-lang.org/installers/${PV}/${PN}-minimal-${PV}-src-builtpkgs.tgz )
+ !minimal? ( https://download.racket-lang.org/installers/${PV}/${P}-src-builtpkgs.tgz )
+"
+S="${WORKDIR}/${P}/src"
+
+# See https://blog.racket-lang.org/2019/11/completing-racket-s-relicensing-effort.html
+LICENSE="|| ( MIT Apache-2.0 ) chez? ( Apache-2.0 ) !chez? ( LGPL-3 )"
+
+# Bytecode generated by Racket is not compatible between versions.
+# The bytecode version should be denoted by SLOT, in most cases
+# PV == SLOT but this has to be checked carefully and in cases
+# where we use _p, _pre, etc it will have to be set manually.
+SLOT="0/${PV}"
+
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="+chez +doc +futures iconv +jit minimal ncurses +places +threads"
+# * "chez" - see bug #809785 re chez/threads
+# * "iconv" - required for "doc"
+REQUIRED_USE="
+ chez? ( futures places ) futures? ( jit threads ) places? ( threads )
+ doc? ( iconv )
+"
+
+RDEPEND="
+ dev-db/sqlite:3
+ dev-libs/libffi:=
+ ncurses? (
+ sys-libs/ncurses:=
+ )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ doc? (
+ >=media-libs/libjpeg-turbo-3.0.3
+ dev-libs/glib:2
+ media-libs/fontconfig
+ x11-libs/cairo
+ x11-libs/pango
+ )
+"
+
+CHECKREQS_DISK_BUILD="1700M"
+# "mred" and "mzscheme" are binaries generated by Racket, not CC
+QA_FLAGS_IGNORED="usr/bin/mred usr/bin/mzscheme"
+
+DOC_CONTENTS="
+If you wish to use sys-libs/readline instead of dev-libs/libedit
+for readline-like features in the Racket's REPL you can install
+the package 'readline-gpl' using raco, Racket's package manager
+https://pkgs.racket-lang.org/package/readline-gpl
+"
+
+# Package database files (for pkg_preinst & pkg_config)
+PKGDB=(
+ /usr/share/racket/info-cache.rktd
+ /usr/share/racket/links.rktd
+ /usr/share/racket/pkgs/pkgs.rktd
+)
+
+src_prepare() {
+ # Prepare the environment.
+ unset PLTADDONDIR PLTCOLLECTS PLTCONFIGDIR PLTUSERHOME
+
+ default
+
+ # Remove bundled libffi.
+ rm -r "${S}/bc/foreign/libffi" || die "failed to remove bundled libffi"
+}
+
+src_configure() {
+ # Compilation of Zuo does not respect the autoconf configuration.
+ tc-export CC
+
+ einfo "Configuring Zuo in ${S}/zuo"
+ pushd "${S}/zuo" >/dev/null || die
+ econf
+ popd >/dev/null || die
+
+ einfo "Configuring Racket in ${S}"
+ # Libtool:
+ # According to vapier, we should use the bundled libtool
+ # such that we don't preclude cross-compile.
+ # Thus don't use --enable-lt=/usr/bin/libtool
+ # Backend:
+ # --enable-bc builds Racket w/o chez backend
+ # C Libraries:
+ # --enable-libs & --disable-shared is the way to build
+ # .a files that are needed to embed Racket into programs
+ # https://docs.racket-lang.org/inside/cs-embedding.html
+ local -a myconf=(
+ --disable-shared
+ --disable-strip
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ --enable-libs
+ $(usex chez "--enable-cs --enable-csonly" "--enable-bc --enable-bconly")
+ $(use_enable doc docs)
+ $(use_enable iconv)
+ $(use_enable ncurses curses)
+ )
+ # Some options are togglable only for the BC version (are forced in CS)
+ ! use chez && myconf+=(
+ --enable-float
+ --enable-foreign
+ --enable-gracket
+ --enable-libffi
+ $(use_enable futures)
+ $(use_enable jit)
+ $(use_enable places)
+ $(use_enable threads pthread)
+ )
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ # Compile Racket.
+ CC_FOR_BUILD="$(tc-getCC)" default
+
+ # Recompile Zuo with optimizations.
+ emake -C zuo
+}
+
+src_install() {
+ # Install Racket.
+ default
+
+ # Install Zuo.
+ emake -C zuo DESTDIR="${ED}" install
+
+ # raco needs decompressed files for packages doc installation, bug #662424
+ use doc && docompress -x "/usr/share/doc/${PF}"
+
+ # Create missing desktop files and icon.
+ if ! use minimal ; then
+ newicon "${ED}/usr/share/racket/drracket-exe-icon.png" racket.png
+
+ make_desktop_entry "gracket" "GRacket" "racket" "Development;Education;"
+ make_desktop_entry "plt-games" "PLT Games" "racket" "Education;Game;"
+ fi
+
+ readme.gentoo_create_doc
+}
+
+pkg_preinst() {
+ # If we are merging the same SLOT check if package
+ # database files exist and do not overwrite them
+ if has_version "${CATEGORY}/${PN}:${SLOT}" ; then
+ echo "We are installing the same SLOT: ${SLOT}"
+
+ local rktd
+ for rktd in "${PKGDB[@]}" ; do
+ if [[ -f "${EROOT}/${rktd}" ]] && [[ -f "${ED}/${rktd}" ]] ; then
+ einfo "Keeping old file: ${rktd}"
+
+ mv "${ED}/${rktd}" "${ED}/${rktd}.bak" ||
+ die "failed to create a backup of ${rktd}"
+
+ cp "${EROOT}/${rktd}" "${ED}/${rktd}" ||
+ die "failed to create a copy of ${rktd}"
+ fi
+ done
+ fi
+}
+
+get_outsiders() {
+ racket -l raco -- pkg show -i | grep 'link' | sed 's|link.*||g'
+}
+
+pkg_postinst() {
+ # If we have any pkgs not included in Racket main distribution (outsiders),
+ # then we have to re-setup them or during installation other pkgs will want
+ # to recompile parts of "outsider" pkgs they depend upon (and fail).
+ local -a outsiders=( $(get_outsiders) )
+ if [[ -n "${outsiders[@]}" ]] ; then
+ ebegin "Running \"raco setup\" for outsider packages"
+ echo "Outsiders: ${outsiders[@]}"
+
+ raco setup --all-users --force --no-docs --no-user --pkgs "${outsiders[@]}"
+ eend 0 # do not fail
+ fi
+
+ optfeature "readline editing features in REPL" dev-libs/libedit
+ optfeature "generating PDF files using Scribble" dev-texlive/texlive-fontsextra
+
+ readme.gentoo_print_elog
+}