summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-scheme/jscheme
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-scheme/jscheme')
-rw-r--r--dev-scheme/jscheme/Manifest1
-rw-r--r--dev-scheme/jscheme/jscheme-7.2.ebuild35
-rw-r--r--dev-scheme/jscheme/metadata.xml13
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-scheme/jscheme/Manifest b/dev-scheme/jscheme/Manifest
new file mode 100644
index 000000000000..6aa88a5aa6a2
--- /dev/null
+++ b/dev-scheme/jscheme/Manifest
@@ -0,0 +1 @@
+DIST jscheme-7.2.tgz 2507622 SHA256 a6460c3903c0dcd9eb8e31be4b3c324ec9f8e2aa43fbc8ec14948b2ea68a67a1 SHA512 48aa1ce806e2dd9bd6797dce6e6569787ad9072f728a39a37310ec5604afdb3fda4ad56a721336d0be9e3c985333ff9dd31cdb809c095d503f54a0f477adc3c7 WHIRLPOOL a12e899807e84922cfb879a88d6f885502260056501d277941bcf7bd7b68ed45dc000377a2e4a23a0bf717a5600756b07b8ed94c2f9734ce95ad03670b6a3965
diff --git a/dev-scheme/jscheme/jscheme-7.2.ebuild b/dev-scheme/jscheme/jscheme-7.2.ebuild
new file mode 100644
index 000000000000..a3cd4a69bbea
--- /dev/null
+++ b/dev-scheme/jscheme/jscheme-7.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit java-utils-2 java-pkg-2
+
+DESCRIPTION="JScheme is a dialect of Scheme with a very simple interface to Java, called the Javadot notation"
+HOMEPAGE="http://jscheme.sourceforge.net/jscheme/main.html"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND=">=virtual/jdk-1.6"
+RDEPEND=">=virtual/jre-1.6
+ ${DEPEND}"
+
+src_compile() {
+ sh bin/make || die "make failed"
+}
+
+src_install() {
+ java-pkg_dojar lib/*.jar
+
+ java-pkg_dolauncher ${PN} \
+ --main jscheme.REPL
+
+ if use doc; then
+ dohtml -r doc || die "dohtml failed"
+ fi
+}
diff --git a/dev-scheme/jscheme/metadata.xml b/dev-scheme/jscheme/metadata.xml
new file mode 100644
index 000000000000..e0944d888fe5
--- /dev/null
+++ b/dev-scheme/jscheme/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>scheme</herd>
+ <longdescription lang="en">
+ JScheme is a dialect of Scheme with a very simple interface to Java, called
+ the Javadot notation . This notation provides a transparent access to all
+ Java classes, constructors, methods, and fields on the classpath.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">jscheme</remote-id>
+ </upstream>
+</pkgmetadata>