summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-04-27 13:25:31 +0200
committerHans de Graaff <graaff@gentoo.org>2023-04-27 13:25:46 +0200
commit9a0f4a116730b24bf4c83eeac17b89c14046be4f (patch)
tree915276a3dfc3a230243ec22707433e5459076acc /dev-ruby
parentdev-ruby/equalizer: update EAPI 7 -> 8 (diff)
downloadgentoo-9a0f4a116730b24bf4c83eeac17b89c14046be4f.tar.gz
gentoo-9a0f4a116730b24bf4c83eeac17b89c14046be4f.tar.bz2
gentoo-9a0f4a116730b24bf4c83eeac17b89c14046be4f.zip
dev-ruby/histogram: update EAPI 7 -> 8
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/histogram/histogram-0.2.4.1-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/histogram/histogram-0.2.4.1-r1.ebuild b/dev-ruby/histogram/histogram-0.2.4.1-r1.ebuild
new file mode 100644
index 000000000000..b36c73cbd6ec
--- /dev/null
+++ b/dev-ruby/histogram/histogram-0.2.4.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Gives objects the ability to 'histogram' in several useful ways"
+HOMEPAGE="https://github.com/jtprince/histogram"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/narray )"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
+}