summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/zentest
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/zentest')
-rw-r--r--dev-ruby/zentest/Manifest2
-rw-r--r--dev-ruby/zentest/metadata.xml8
-rw-r--r--dev-ruby/zentest/zentest-4.11.0.ebuild29
-rw-r--r--dev-ruby/zentest/zentest-4.9.5.ebuild34
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-ruby/zentest/Manifest b/dev-ruby/zentest/Manifest
new file mode 100644
index 000000000000..033811b10611
--- /dev/null
+++ b/dev-ruby/zentest/Manifest
@@ -0,0 +1,2 @@
+DIST ZenTest-4.11.0.gem 71680 SHA256 c81b515c0a620379877edad823aad8e155700166e6a7f6e441e7b1c5729fa05e SHA512 cb835ea2e937b7ea56084c138948acb1c2a96500e5b8bd54dd9d195e4005ebdce67b189cdf31a010135f55adb02f3bcf21ff663a26022eb759dd2126558c5c21 WHIRLPOOL f6d827937a33a448d9cfc530b3da235e3694256c55bf57242f440f3aab427ad249ef2fc1e58b4dd5a80a29ccb7b8e359b5a2e1989a631da090461e745e67e52e
+DIST ZenTest-4.9.5.gem 71168 SHA256 8d93c6fd25e3040661f24829bb97f37973c8b99ee0b52c91dfdc2a1d5a120b5f SHA512 00663bb5d78782c48db14e8dc29b2b2d1ec49beab0b1f907a0fae95b04f3d8124de09fa477111cfebfaa68847361aeda5215cae0e1c5b591ba9fd978663aec91 WHIRLPOOL 3f647cc3ab3f88b6b3253503d0c7bf6baeb423c712eacbdafc88969b7e2314a37408555e7cd8842d252472d451a7658e8e08961e6143c95ce97c38a6994a220a
diff --git a/dev-ruby/zentest/metadata.xml b/dev-ruby/zentest/metadata.xml
new file mode 100644
index 000000000000..1f10a6bb3dfa
--- /dev/null
+++ b/dev-ruby/zentest/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">seattlerb/zentest</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/zentest/zentest-4.11.0.ebuild b/dev-ruby/zentest/zentest-4.11.0.ebuild
new file mode 100644
index 000000000000..ad6d98793609
--- /dev/null
+++ b/dev-ruby/zentest/zentest-4.11.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_NAME=ZenTest
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt example.txt example1.rb example2.rb example_dot_autotest.rb"
+
+inherit ruby-fakegem
+
+DESCRIPTION="ZenTest provides tools to support testing: zentest, unit_diff, autotest, multiruby, and Test::Rails"
+HOMEPAGE="https://github.com/seattlerb/zentest"
+LICENSE="Ruby"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/hoe-2.10
+ dev-ruby/hoe-seattlerb
+ dev-ruby/minitest:5
+ )"
diff --git a/dev-ruby/zentest/zentest-4.9.5.ebuild b/dev-ruby/zentest/zentest-4.9.5.ebuild
new file mode 100644
index 000000000000..eb9f1a1f7e8a
--- /dev/null
+++ b/dev-ruby/zentest/zentest-4.9.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_NAME=ZenTest
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt example.txt example1.rb example2.rb example_dot_autotest.rb"
+
+inherit ruby-fakegem
+
+DESCRIPTION="ZenTest provides tools to support testing: zentest, unit_diff, autotest, multiruby, and Test::Rails"
+HOMEPAGE="https://github.com/seattlerb/zentest"
+LICENSE="Ruby"
+
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "
+ doc? (
+ >=dev-ruby/hoe-2.10
+ dev-ruby/hoe-seattlerb
+ )
+ test? (
+ >=dev-ruby/hoe-2.10
+ dev-ruby/hoe-seattlerb
+ dev-ruby/minitest:5
+ )"