summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-03-13 07:38:15 +0100
committerHans de Graaff <graaff@gentoo.org>2016-03-13 07:38:15 +0100
commit24849d007acc23861d55260f291cc599b907cfc0 (patch)
tree71354f7bdbd005c0733f782e5124fbb95356001c /dev-ruby/webrobots
parentapp-emulation/wine: Exclude staging patch that breaks -nls, Bug #577198 (diff)
downloadgentoo-24849d007acc23861d55260f291cc599b907cfc0.tar.gz
gentoo-24849d007acc23861d55260f291cc599b907cfc0.tar.bz2
gentoo-24849d007acc23861d55260f291cc599b907cfc0.zip
dev-ruby/webrobots: add 0.1.2
Drop ppc, x86 keywords due to missing webmock keywords, bug 563858 Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-ruby/webrobots')
-rw-r--r--dev-ruby/webrobots/Manifest1
-rw-r--r--dev-ruby/webrobots/webrobots-0.1.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/webrobots/Manifest b/dev-ruby/webrobots/Manifest
index 255489694e4a..34066f787fda 100644
--- a/dev-ruby/webrobots/Manifest
+++ b/dev-ruby/webrobots/Manifest
@@ -1 +1,2 @@
DIST webrobots-0.1.1.gem 17408 SHA256 568c5e5a149c5e7fbd5065522bb986ddd8f147e8586818ab7e79d6a02e8496ca SHA512 f303c238620d17cb64064d11eb352d2afb32529f7092609484e5e232ccbc903683f89116a0e5232605b6d0286a4a76b82e71e44884a7b77d12125f3b3c6c5a34 WHIRLPOOL e7fa930ccebb17b0d785c3a4d0257d6fcd255816913b7a8e1f3c8ec4cd1a0e42d9040c30e6a3b4e28114dfc106f60c6161f6f4055686c0c6688bc781d6772b00
+DIST webrobots-0.1.2.gem 24064 SHA256 ebbcaa2cb4930fa1b83206f432c5cb64746507b2dcf50ea1301569a4d662cda6 SHA512 8b2a27a1758e613bced16b59a2b1708f468921388882d7ea483c7b6cbb5173fa24032f4db271734820225c5e90d3f30d07c5fb682d0d807c637f535ef7256097 WHIRLPOOL d353c46d54a26410b5bea9bd706e977e15b0a20af44d3764dd668ae86dd1fc9d6cbc2d94d91b5955f547dfc3589457f5654a706b53a2d7a702bb45a604edf1cf
diff --git a/dev-ruby/webrobots/webrobots-0.1.2.ebuild b/dev-ruby/webrobots/webrobots-0.1.2.ebuild
new file mode 100644
index 000000000000..eaf85376364a
--- /dev/null
+++ b/dev-ruby/webrobots/webrobots-0.1.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library to help write robots.txt compliant web robots"
+HOMEPAGE="https://github.com/knu/webrobots"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/nokogiri-1.4.4"
+
+ruby_add_bdepend "test? ( dev-ruby/shoulda dev-ruby/test-unit:2 dev-ruby/webmock )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/,/end/d' Rakefile test/helper.rb || die
+
+ # Avoid tests for live websites requirering a network connection.
+ sed -i -e '/robots.txt in the real world/,/^ end/ s:^:#:' test/test_webrobots.rb || die
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib test/test_*.rb
+}