summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/ruby2ruby
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/ruby2ruby')
-rw-r--r--dev-ruby/ruby2ruby/Manifest3
-rw-r--r--dev-ruby/ruby2ruby/metadata.xml8
-rw-r--r--dev-ruby/ruby2ruby/ruby2ruby-2.0.6.ebuild31
-rw-r--r--dev-ruby/ruby2ruby/ruby2ruby-2.1.4.ebuild32
-rw-r--r--dev-ruby/ruby2ruby/ruby2ruby-2.2.0.ebuild32
5 files changed, 106 insertions, 0 deletions
diff --git a/dev-ruby/ruby2ruby/Manifest b/dev-ruby/ruby2ruby/Manifest
new file mode 100644
index 000000000000..26a63c0c7ee2
--- /dev/null
+++ b/dev-ruby/ruby2ruby/Manifest
@@ -0,0 +1,3 @@
+DIST ruby2ruby-2.0.6.gem 20992 SHA256 b2fbb49b66191983db0b9532c81b1eeb446e3af7cced0995401c43637a7407ae SHA512 869c8b8f9ca21bcda184e9cc73d85e8f291c3b02b3d4e738fe305b6dec7cc93f2d988090441af7e5cef034c7596837136f293996110c9b7f11d5b108654b4a75 WHIRLPOOL ae50b1faab6540234322687776ea05e33779f03eccc7f90f085b8a3d072cd752c3779b26c7dde2edf778860f8eab0d67af0c03bb06047c14e3dddd136919b434
+DIST ruby2ruby-2.1.4.gem 24576 SHA256 355e7d8e3c0e2a846c74aace24dfdb8fe3de01311ade2453735f69b6a3e40bc0 SHA512 e436902cdae8628ce49c676350594c220e86a1c356fc6924d845c7774c0de488349050fcbd9df98cb73ed9c66f770b0bed173486d4fab58dab665991fdbe74c9 WHIRLPOOL aaf261aede3c59c1bfec955c5ad7355991136a3ce984160e8cb5d251003d0817735dc8e08312515301699b95ec36c06fbf6d458ff2921f4ebfd710bd7a4856c9
+DIST ruby2ruby-2.2.0.gem 25088 SHA256 f59a681a26f2f2219eca8340064a913ffd6fa2e6a1f4ebbdb4b8263d4001acce SHA512 d5ca1cab8e83f5fef31c5d471e0285fc17ccd1477ce16717d20581868e99fecb3002ff3d9d000782fa7e00b99f9c647c5cae6a5162dafc9613652e86d756fef3 WHIRLPOOL 2d16f5b4e737d1c860159af39798788a7b9ad603b243ff70191f1fbda544513b0ec4f4340106099a6890f866a4aed41865f56fd5cb4d07561504ffbf27c63311
diff --git a/dev-ruby/ruby2ruby/metadata.xml b/dev-ruby/ruby2ruby/metadata.xml
new file mode 100644
index 000000000000..770eb616ff9b
--- /dev/null
+++ b/dev-ruby/ruby2ruby/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">seattlerb/ruby2ruby</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/ruby2ruby/ruby2ruby-2.0.6.ebuild b/dev-ruby/ruby2ruby/ruby2ruby-2.0.6.ebuild
new file mode 100644
index 000000000000..81b25776d92a
--- /dev/null
+++ b/dev-ruby/ruby2ruby/ruby2ruby-2.0.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Generates readable ruby from ParseTree"
+HOMEPAGE="http://seattlerb.rubyforge.org/"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "
+ dev-ruby/sexp_processor:4
+ dev-ruby/ruby_parser:3
+ !<dev-ruby/ruby2ruby-1.3.1-r1"
+ruby_add_bdepend "doc? ( dev-ruby/hoe dev-ruby/hoe-seattlerb )"
+
+all_ruby_prepare() {
+ sed -i -e '/plugin :isolate/ s:^:#:' Rakefile || die
+}
diff --git a/dev-ruby/ruby2ruby/ruby2ruby-2.1.4.ebuild b/dev-ruby/ruby2ruby/ruby2ruby-2.1.4.ebuild
new file mode 100644
index 000000000000..cb839f22211b
--- /dev/null
+++ b/dev-ruby/ruby2ruby/ruby2ruby-2.1.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Generates readable ruby from ParseTree"
+HOMEPAGE="http://seattlerb.rubyforge.org/"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ~ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+ruby_add_rdepend "
+ dev-ruby/sexp_processor:4
+ >=dev-ruby/ruby_parser-3.1:3
+ !<dev-ruby/ruby2ruby-1.3.1-r1"
+ruby_add_bdepend "doc? ( dev-ruby/hoe dev-ruby/hoe-seattlerb )
+ test? ( >=dev-ruby/minitest-5.3:5 )"
+
+all_ruby_prepare() {
+ sed -i -e '/plugin :isolate/ s:^:#:' Rakefile || die
+}
diff --git a/dev-ruby/ruby2ruby/ruby2ruby-2.2.0.ebuild b/dev-ruby/ruby2ruby/ruby2ruby-2.2.0.ebuild
new file mode 100644
index 000000000000..12776eb3980e
--- /dev/null
+++ b/dev-ruby/ruby2ruby/ruby2ruby-2.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Generates readable ruby from ParseTree"
+HOMEPAGE="https://github.com/seattlerb/ruby2ruby"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+ruby_add_rdepend "
+ >=dev-ruby/sexp_processor-4.6.0:4
+ >=dev-ruby/ruby_parser-3.1:3
+ !<dev-ruby/ruby2ruby-1.3.1-r1"
+ruby_add_bdepend "doc? ( dev-ruby/hoe dev-ruby/hoe-seattlerb )
+ test? ( >=dev-ruby/minitest-5.3:5 )"
+
+all_ruby_prepare() {
+ sed -i -e '/plugin :isolate/ s:^:#:' Rakefile || die
+}