summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/ruby-net-ldap
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/ruby-net-ldap')
-rw-r--r--dev-ruby/ruby-net-ldap/Manifest3
-rw-r--r--dev-ruby/ruby-net-ldap/metadata.xml8
-rw-r--r--dev-ruby/ruby-net-ldap/ruby-net-ldap-0.11.ebuild29
-rw-r--r--dev-ruby/ruby-net-ldap/ruby-net-ldap-0.7.0.ebuild36
-rw-r--r--dev-ruby/ruby-net-ldap/ruby-net-ldap-0.8.0.ebuild38
5 files changed, 114 insertions, 0 deletions
diff --git a/dev-ruby/ruby-net-ldap/Manifest b/dev-ruby/ruby-net-ldap/Manifest
new file mode 100644
index 000000000000..243c414fe014
--- /dev/null
+++ b/dev-ruby/ruby-net-ldap/Manifest
@@ -0,0 +1,3 @@
+DIST net-ldap-0.11.gem 87040 SHA256 fc5487b0c81cbf2beaede0e6c07af036559deb4ab6df185f61ac16562949d8f5 SHA512 8894fac34df186f03b879e707504ce8952030d38d88e902c8a98f195503765f7780771f26775606ff84a7940cd3b1a8193e028f85d05130940d583c222b4cc1f WHIRLPOOL 67d40f4ca3cb640aeb4a315ab2df44256357a6528c9fa3c69be20e1c2a26f1672c7a2c15afb5111f731dd8f0613000b1f6a9c2624230b62ebd67f64dab6f8ce0
+DIST net-ldap-0.7.0.gem 70656 SHA256 d39d341c992abb7273d8b83cbe32a38e69fdeb4eab684dbd2db1232e4065a4b4 SHA512 71000b05bcf7db8a3c40f6311e16385f2569df12c5b193c454dc2ebd043af0183d650626d8805c0e58e59aa842091da1fba37e35cdb58789279ef5b93ad13e7f WHIRLPOOL 6fbbe9a6ffe1832db61d2eb5cacba4675be9cf9bb7dc9d7102e3c04f244dc7572e2a19d96c62b5e6c77b64467d6efe0e76ad9fcc74837b2404387f2ea8c5ea94
+DIST net-ldap-0.8.0.gem 72704 SHA256 e1b7f21b58a4c2ff6f2c3361f584342017f46d4a965f377f192b4cd8855b0242 SHA512 3083a9bb61a048213d524d9795ac61b38d07abd4788b5504b9d642062f9fcf947120c98e10a76d8e3be0dc91b680bae50b056bd9fcd75cdb4a1af2e907953cf9 WHIRLPOOL e6767bc2985faa6262743d9a6273abe2d693c4d12b21fb5dcc256a49634b059fc2bf831a21ce37128158ff18045e8630790eea2bbda8106dca262b392533ddfa
diff --git a/dev-ruby/ruby-net-ldap/metadata.xml b/dev-ruby/ruby-net-ldap/metadata.xml
new file mode 100644
index 000000000000..ea68e18056a2
--- /dev/null
+++ b/dev-ruby/ruby-net-ldap/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">ruby-ldap/ruby-net-ldap</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/ruby-net-ldap/ruby-net-ldap-0.11.ebuild b/dev-ruby/ruby-net-ldap/ruby-net-ldap-0.11.ebuild
new file mode 100644
index 000000000000..e83b8d910be1
--- /dev/null
+++ b/dev-ruby/ruby-net-ldap/ruby-net-ldap-0.11.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_TEST="test spec"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="Contributors.rdoc History.rdoc README.rdoc"
+
+RUBY_FAKEGEM_NAME="net-ldap"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pure ruby LDAP client implementation"
+HOMEPAGE="https://github.com/ruby-ldap/ruby-net-ldap"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+
+ruby_add_bdepend "test? ( >=dev-ruby/flexmock-1.3.0 )"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
+}
diff --git a/dev-ruby/ruby-net-ldap/ruby-net-ldap-0.7.0.ebuild b/dev-ruby/ruby-net-ldap/ruby-net-ldap-0.7.0.ebuild
new file mode 100644
index 000000000000..5981aa2faf64
--- /dev/null
+++ b/dev-ruby/ruby-net-ldap/ruby-net-ldap-0.7.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+# jruby: requires ruby 1.9 compatibility
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_TEST="test spec"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="Contributors.rdoc History.rdoc README.rdoc"
+
+RUBY_FAKEGEM_NAME="net-ldap"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pure ruby LDAP client implementation"
+HOMEPAGE="https://github.com/ruby-ldap/ruby-net-ldap"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+
+ruby_add_bdepend "test? ( >=dev-ruby/flexmock-1.3.0
+ >=dev-ruby/metaid-1
+ dev-ruby/test-unit:2
+ dev-ruby/rspec:2 )"
+
+all_ruby_prepare() {
+ sed -i -e '1igem "test-unit"' test/common.rb || die
+
+ # Avoid an integration spec that hangs due to setting up pipes and
+ # intercepting openssl connect calls.
+ rm spec/integration/ssl_ber_spec.rb || die
+}
diff --git a/dev-ruby/ruby-net-ldap/ruby-net-ldap-0.8.0.ebuild b/dev-ruby/ruby-net-ldap/ruby-net-ldap-0.8.0.ebuild
new file mode 100644
index 000000000000..db2ed66dd636
--- /dev/null
+++ b/dev-ruby/ruby-net-ldap/ruby-net-ldap-0.8.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+# jruby: requires ruby 1.9 compatibility
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_TEST="test spec"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="Contributors.rdoc History.rdoc README.rdoc"
+
+RUBY_FAKEGEM_NAME="net-ldap"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pure ruby LDAP client implementation"
+HOMEPAGE="https://github.com/ruby-ldap/ruby-net-ldap"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+
+ruby_add_bdepend "test? ( >=dev-ruby/flexmock-1.3.0
+ >=dev-ruby/metaid-1
+ dev-ruby/test-unit:2
+ dev-ruby/rspec:2 )"
+
+all_ruby_prepare() {
+ sed -i -e '1igem "test-unit"' test/common.rb || die
+
+ # Fix Specs until RSpec:3 is in tree
+ sed -i -e 's/truthy/true/' spec/unit/ldap_spec.rb || die
+ # Avoid an integration spec that hangs due to setting up pipes and
+ # intercepting openssl connect calls.
+ rm spec/integration/ssl_ber_spec.rb || die
+}