summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-08-26 17:37:42 +0200
committerHans de Graaff <graaff@gentoo.org>2023-08-26 17:39:27 +0200
commitd69c1fd82ce8cd24e15cb0447c946f62f3209ef1 (patch)
treeebb060542fb972024333729278556b030dbd837a /dev-ruby/rspec-core
parentdev-ruby/rspec: drop 3.11.0 (diff)
downloadgentoo-d69c1fd82ce8cd24e15cb0447c946f62f3209ef1.tar.gz
gentoo-d69c1fd82ce8cd24e15cb0447c946f62f3209ef1.tar.bz2
gentoo-d69c1fd82ce8cd24e15cb0447c946f62f3209ef1.zip
dev-ruby/rspec-core: drop 3.11.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rspec-core')
-rw-r--r--dev-ruby/rspec-core/Manifest1
-rw-r--r--dev-ruby/rspec-core/rspec-core-3.11.0.ebuild91
2 files changed, 0 insertions, 92 deletions
diff --git a/dev-ruby/rspec-core/Manifest b/dev-ruby/rspec-core/Manifest
index b061ae418a4b..46e771a3361f 100644
--- a/dev-ruby/rspec-core/Manifest
+++ b/dev-ruby/rspec-core/Manifest
@@ -1,3 +1,2 @@
-DIST rspec-core-3.11.0-git.tgz 403154 BLAKE2B 1a5043bd2120236e8e3ca931c1fd9562bc78d692674d3133ac3742ef7b7f81161a7fc550f4d11bf34575a85a8657aeb39fcc0fdccaab67cc189cc1d39a303ade SHA512 6121b805f6feade244fe13e273526e64c5a3c74a1f9d4316c895279f4ed8576dbe3189b06040f3f29fe7d3e90f862f2c78aacb0b4bef989660eae30d046ed69c
DIST rspec-core-3.12.1-git.tgz 409036 BLAKE2B 0a6311f9908fd2e85621ebdb9cce5723de83e392bc5a6f0bb5be98c26b8f26b759a1cb3923a5d583f2ea7f6e72f07093bb23d54aa2b44d3a3ae0874ef6a99a73 SHA512 aaf7e4aebf1240c5f602a1e34f1f9e9355438ca544484f500d21e6021fd95d5ab5d26dc2249122d1dfc76b23725800f88937b5d1e53cd00d0b84faa46b056bea
DIST rspec-core-3.12.2-git.tgz 409039 BLAKE2B 087b08b6a5231a050d89dc8ec1648509b47078b54c05e5effc02cfcdd0f4cae9fa85f7dc02d643a6e81eb9e4c1dca54d6f4e0b0f79a5d91072c1934fddac9169 SHA512 6ecd39355a5060dbf820b89f2f5958b7e75a185e003036cb0ceb8dd6021d79fa14495a300acdc019b55e174bf8a6be42022bfeb0f22a35c461c0f81cd1a742fd
diff --git a/dev-ruby/rspec-core/rspec-core-3.11.0.ebuild b/dev-ruby/rspec-core/rspec-core-3.11.0.ebuild
deleted file mode 100644
index ae6815f1da1d..000000000000
--- a/dev-ruby/rspec-core/rspec-core-3.11.0.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby26 ruby27 ruby30 ruby31"
-
-RUBY_FAKEGEM_TASK_TEST="none"
-
-RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
-
-# Also install this custom path since internal paths depend on it.
-RUBY_FAKEGEM_EXTRAINSTALL="exe"
-
-RUBY_FAKEGEM_GEMSPEC="rspec-core.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
-HOMEPAGE="https://github.com/rspec/rspec-core"
-SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
-
-LICENSE="MIT"
-SLOT="3"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="highlight"
-
-SUBVERSION="$(ver_cut 1-2)"
-
-ruby_add_rdepend "
- =dev-ruby/rspec-support-${SUBVERSION}*
- highlight? ( >=dev-ruby/coderay-1.1.1 )
-"
-
-ruby_add_bdepend "test? (
- >=dev-ruby/nokogiri-1.5.2
- >=dev-ruby/coderay-1.1.1
- dev-ruby/syntax
- >=dev-ruby/thread_order-1.1.0
- >=dev-ruby/rspec-expectations-3.8.0:3
- >=dev-ruby/rspec-mocks-2.99.0:3
- >=dev-ruby/rspec-support-3.9.1:3
- )"
-
-all_ruby_prepare() {
- # Don't set up bundler: it doesn't understand our setup.
- sed -i -e '/[Bb]undler/d' Rakefile || die
-
- # Avoid dependency on cucumber since we can't run the features anyway.
- sed -i -e '/[Cc]ucumber/ s:^:#:' Rakefile || die
-
- # Duplicate exe also in bin. We can't change it since internal stuff
- # also depends on this and fixing that is going to be fragile. This
- # way we can at least install proper bin scripts.
- cp -R exe bin || die
-
- # Avoid unneeded dependency on git.
- sed -i -e 's/git ls-files --/find/' rspec-core.gemspec || die
-
- # Avoid aruba dependency so that we don't end up in dependency hell.
- sed -i -e '/ArubaLoader/,/^end/ s:^:#:' -e '/Aruba/ s:^:#:' spec/spec_helper.rb || die
- rm -f spec/support/aruba_support.rb || die
- rm -f spec/integration/{bisect_runners,failed_line_detection,filtering,order,persistence_failures,suite_hooks_errors}_spec.rb || die
- rm -f spec/integration/{spec_file_load_errors,output_stream,fail_if_no_examples}_spec.rb || die
-
- # Avoid a spec failing due to path issues
- sed -i -e '/does not load files in the default path when run by ruby/,/end/ s:^:#:' \
- spec/rspec/core/configuration_spec.rb || die
-
- # Avoid a spec that depends on dev-ruby/rspec to lessen circular
- # dependencies, bug 662328
- sed -i -e '/loads mocks and expectations when the constants are referenced/askip "gentoo: bug 662328"' spec/rspec/core_spec.rb || die
-
- # Avoid a spec depending on specifics on local networks
- # This fails when localhost resolves to ::1 which may be a
- # ruby regression in the drb/acl code.
- rm -f spec/rspec/core/bisect/server_spec.rb || die
-}
-
-each_ruby_prepare() {
- sed -i -e 's:ruby -e:'${RUBY}' -e:' spec/rspec/core_spec.rb || die
-}
-
-each_ruby_test() {
- PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -Ilib bin/rspec spec || die "Tests failed."
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- ruby_fakegem_binwrapper rspec /usr/bin/rspec-3 'gem "rspec", "~>3.0"'
-}