summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-05-23 07:13:36 +0200
committerHans de Graaff <graaff@gentoo.org>2024-05-23 08:13:35 +0200
commit5adbaf9bbfdf5759e609cf6a18097d125d5c80b2 (patch)
treec378da961a796b304bb351d68a93a9350fec3a78 /dev-ruby/regexp_property_values
parentdev-ruby/regexp_parser: add 2.9.2 (diff)
downloadgentoo-5adbaf9bbfdf5759e609cf6a18097d125d5c80b2.tar.gz
gentoo-5adbaf9bbfdf5759e609cf6a18097d125d5c80b2.tar.bz2
gentoo-5adbaf9bbfdf5759e609cf6a18097d125d5c80b2.zip
dev-ruby/regexp_property_values: add 1.5.2
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/regexp_property_values')
-rw-r--r--dev-ruby/regexp_property_values/Manifest1
-rw-r--r--dev-ruby/regexp_property_values/regexp_property_values-1.5.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/regexp_property_values/Manifest b/dev-ruby/regexp_property_values/Manifest
index f4fb3307ca6c..19941782f1ef 100644
--- a/dev-ruby/regexp_property_values/Manifest
+++ b/dev-ruby/regexp_property_values/Manifest
@@ -1,2 +1,3 @@
DIST regexp_property_values-1.4.0.tar.gz 13719 BLAKE2B e0569e5387d5186829e40a8fdeec1fbd8534356ec73cce5525b6259938534fe8d1e3a15664faa7903a93e5a7330e6cbc6281b79be74cd4d1b13865084e1f42a4 SHA512 f8b425f001f4b9f6b373d9b47d7b87baf369719c2ae1385d68932f31d0a392086d3ed8b48461cbf59568668722975a98935c56fa470ce7ba466c29a30442bf6e
DIST regexp_property_values-1.5.1.tar.gz 13901 BLAKE2B 32236b67ff4fc932fc30638a8fc85745d2c74445d4009c06de94652b82238599dd90e73d9ebd63690604fd1c3d413cddba3290a732150726126dcd3361f5eb47 SHA512 0787105195c22cfb499d37e5a2adb7ca52d23d291280ed9b5dcc38e6b03d260e341bdf56ba1bf643cc6cdf9436fe2287e5f139cdbd11cf4c71da256767f75754
+DIST regexp_property_values-1.5.2.tar.gz 14306 BLAKE2B 77954b5af6ac525420feabcb904967addd284bd4f79ad38c12048aaf38001e7a108056016ae35d850dc476eb8d91aef049d16d466f03c14a4b2c5f50740f30f1 SHA512 08d57ae06628c4ddd2485c72da0568eaac0520ef8aade142771c9effef97d8021352fb4cc84cffeebcd7cb27987cef965f2109a6cd91226f8a1a42023739dab6
diff --git a/dev-ruby/regexp_property_values/regexp_property_values-1.5.2.ebuild b/dev-ruby/regexp_property_values/regexp_property_values-1.5.2.ebuild
new file mode 100644
index 000000000000..dd0be2885d42
--- /dev/null
+++ b/dev-ruby/regexp_property_values/regexp_property_values-1.5.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/regexp_property_values/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR="lib/regexp_property_values"
+
+inherit ruby-fakegem
+
+DESCRIPTION="See which property values are supported by the regular expression engine"
+HOMEPAGE="https://github.com/jaynetics/regexp_property_values"
+SRC_URI="https://github.com/jaynetics/regexp_property_values/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/bundler/ s:^:#:' spec/spec_helper.rb || die
+
+ # Avoid dependency on character_set which would lead to circular
+ # dependencies.
+ sed -e '/returns a CharacterSet/askip "gentoo circular dependencies"' \
+ -i spec/regexp_property_values/value_spec.rb || die
+}