summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/rake
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/rake')
-rw-r--r--dev-ruby/rake/Manifest4
-rw-r--r--dev-ruby/rake/files/rake.bash-completion54
-rw-r--r--dev-ruby/rake/metadata.xml9
-rw-r--r--dev-ruby/rake/rake-0.9.6-r1.ebuild64
-rw-r--r--dev-ruby/rake/rake-0.9.6.ebuild64
-rw-r--r--dev-ruby/rake/rake-10.3.2.ebuild54
-rw-r--r--dev-ruby/rake/rake-10.4.0.ebuild54
-rw-r--r--dev-ruby/rake/rake-10.4.2.ebuild49
8 files changed, 352 insertions, 0 deletions
diff --git a/dev-ruby/rake/Manifest b/dev-ruby/rake/Manifest
new file mode 100644
index 000000000000..fb2b374c4d5b
--- /dev/null
+++ b/dev-ruby/rake/Manifest
@@ -0,0 +1,4 @@
+DIST rake-0.9.6.gem 123904 SHA256 0cde8637bc097b984b602d7db77b1982b3a0be5ab014f1e533b6b517ca807e26 SHA512 9ea3b7bd96db7e96f8bf5a00db710003d39ffeea6eabfde4b9a8afead0e6f6a8fa7740f42a61d77a4322f64ab0338b19af8c63d0178624dc7c0e787e11b0b6f3 WHIRLPOOL 90ab856325bd4c4a3944720e063156d65368298658ed0619380da4cdbc7c932ede44e39fd79f87f5a5ed6ce63f4c7d01c0d1f06ee1b720e3576ac6ba04290e03
+DIST rake-10.3.2.gem 132608 SHA256 b504ad9d610b85ef0856a4771d024e4a66656c63a17121a3ed1d4d7db39c775b SHA512 98db69b02bc8d1e5b7099c8c31028ebb629d29a96b61c4200f93fe1a8b5b29fe235a4a8ccb180e44393a508a6238a0655d06f6b7fd7d67ffbca5dd42cf50da15 WHIRLPOOL 30d34219b48367a62bdc01127672c21039d8c66559e65d34acb8dbc07a747d5d7a7b8f80bde459ad38c963cb88c1fcf34c4ebb13018be0a48bd30030f12f4603
+DIST rake-10.4.0.gem 130560 SHA256 887f72d6711c31576abab37f1f7db45972402cc8544fa9a67c06d2c0f0ef2028 SHA512 8b9c0e3b56bd9b47540c8c7a67fb019417e991cb15eac4de46cc611ab0d6838a931dd7b59b198a083c256dde488c767cde31d7fe18fc894c80cfcffc1a8d404f WHIRLPOOL fb21d20241288d15fd252f364853d506f223becfa88966987ded24609dd8350d3840e2770eb7ae6f9d4d9a9ea915df82632c369a7c22aecf0262e1405fc49898
+DIST rake-10.4.2.gem 130560 SHA256 28970905a7bb57ba7ebcd2eda820ccea622f549b101d7590353b0647711ec0e6 SHA512 6663cd785fc0f3fe6096f962cbb01e4300446a21aa57a4784f3b79cb3228895a8a207c32463888e243d425c168ae5361e9192d86c878e0535bf4ac061a80ce51 WHIRLPOOL 2fd3590ba2d3c333e724a4193b25064f03cf50f9216da9654fecc1e36369681f892d993e9bac135babcbac47cac562c46d20f5f05a4544ec62de4ae558f0b996
diff --git a/dev-ruby/rake/files/rake.bash-completion b/dev-ruby/rake/files/rake.bash-completion
new file mode 100644
index 000000000000..dbdfbd02c410
--- /dev/null
+++ b/dev-ruby/rake/files/rake.bash-completion
@@ -0,0 +1,54 @@
+_rake()
+{
+ local cur prev rakef i
+
+ COMPREPLY=()
+ cur=${COMP_WORDS[COMP_CWORD]}
+ prev=${COMP_WORDS[COMP_CWORD-1]}
+ rakef="Rakefile"
+
+ if [[ "$prev" == "-f" ]]; then
+ _filedir
+ return 0
+ fi
+
+ if [[ "$cur" == *=* ]]; then
+ prev=${cur/=*/}
+ cur=${cur/*=/}
+ if [[ "$prev" == "--rakefile=" ]]; then
+ _filedir -o nospace
+ return 0
+ fi
+ fi
+
+ if [[ "$cur" == -* ]]; then
+ COMPREPLY=( $( compgen -W '-n -H -I -N -P -q -f\
+ -r -s -T -t -h -v -V\
+ --dry-run --help '--libdir=' --nosearch --prereqs --quiet\
+ '--rakefile=' '--require=' --silent --tasks --trace --usage\
+ --verbose --version'\
+ -- $cur ))
+ else
+
+ for (( i=0; i < ${#COMP_WORDS[@]}; i++)); do
+ case "${COMP_WORDS[i]}" in
+ -f)
+ eval rakef=${COMP_WORDS[i+1]}
+ break
+ ;;
+ --rakefile=*|--rakefile\=*)
+ eval rakef=${COMP_WORDS[i]/*=/}
+ break
+ ;;
+ esac
+ done
+
+ [ ! -f $rakef ] && return 0
+
+ COMPREPLY=( $( rake -s -f "$rakef" -T | \
+ awk -F ' ' '/^rake / { print $2 }' | \
+ command grep "^$cur" ))
+
+ fi
+} &&
+complete -F _rake $filenames rake
diff --git a/dev-ruby/rake/metadata.xml b/dev-ruby/rake/metadata.xml
new file mode 100644
index 000000000000..76282fc962ae
--- /dev/null
+++ b/dev-ruby/rake/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="rubyforge">rake</remote-id>
+ <remote-id type="github">jimweirich/rake</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rake/rake-0.9.6-r1.ebuild b/dev-ruby/rake/rake-0.9.6-r1.ebuild
new file mode 100644
index 000000000000..52798607888a
--- /dev/null
+++ b/dev-ruby/rake/rake-0.9.6-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.rdoc TODO"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit bash-completion-r1 ruby-fakegem
+
+DESCRIPTION="Make-like scripting in Ruby"
+HOMEPAGE="https://github.com/jimweirich/rake"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~hppa ~ia64 ~mips ppc ~ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc"
+
+DEPEND="${DEPEND} app-arch/gzip"
+RDEPEND="${RDEPEND}"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )
+ test? ( virtual/ruby-minitest )"
+
+all_ruby_prepare() {
+ # Comment out unimportant test which failes on ruby18 at least.
+ sed -i -e '/def test_classic_namespace/,/^ end/ s:^:#:' test/test_rake_application_options.rb || die
+
+ # Avoid tests which can't work in bootstrapping because the test runs
+ # in a directory that can't access the file being loaded.
+ rm test/test_rake_clean.rb || die
+ sed -i -e '/test_run_code_rake/,/^ end/ s:^:#:' test/test_rake_test_task.rb || die
+
+ # Decompress the file. The compressed version has errors, ignore them.
+ zcat doc/rake.1.gz > doc/rake.1
+}
+
+all_ruby_compile() {
+ if use doc; then
+ ruby -Ilib bin/rake rdoc || die "doc generation failed"
+ fi
+}
+
+each_ruby_test() {
+ ${RUBY} -S testrb test/test_*.rb || die
+}
+
+all_ruby_install() {
+ ruby_fakegem_binwrapper rake
+
+ if use doc; then
+ pushd html
+ dohtml -r *
+ popd
+ fi
+
+ doman doc/rake.1
+
+ newbashcomp "${FILESDIR}"/rake.bash-completion ${PN}
+}
diff --git a/dev-ruby/rake/rake-0.9.6.ebuild b/dev-ruby/rake/rake-0.9.6.ebuild
new file mode 100644
index 000000000000..b8bf8b56963b
--- /dev/null
+++ b/dev-ruby/rake/rake-0.9.6.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.rdoc TODO"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit bash-completion-r1 ruby-fakegem
+
+DESCRIPTION="Make-like scripting in Ruby"
+HOMEPAGE="https://github.com/jimweirich/rake"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc"
+
+DEPEND="${DEPEND} app-arch/gzip"
+RDEPEND="${RDEPEND}"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )
+ test? ( virtual/ruby-minitest )"
+
+all_ruby_prepare() {
+ # Comment out unimportant test which failes on ruby18 at least.
+ sed -i -e '/def test_classic_namespace/,/^ end/ s:^:#:' test/test_rake_application_options.rb || die
+
+ # Avoid tests which can't work in bootstrapping because the test runs
+ # in a directory that can't access the file being loaded.
+ rm test/test_rake_clean.rb || die
+ sed -i -e '/test_run_code_rake/,/^ end/ s:^:#:' test/test_rake_test_task.rb || die
+
+ # Decompress the file. The compressed version has errors, ignore them.
+ zcat doc/rake.1.gz > doc/rake.1
+}
+
+all_ruby_compile() {
+ if use doc; then
+ ruby -Ilib bin/rake rdoc || die "doc generation failed"
+ fi
+}
+
+each_ruby_test() {
+ ${RUBY} -S testrb test/test_*.rb || die
+}
+
+all_ruby_install() {
+ ruby_fakegem_binwrapper rake
+
+ if use doc; then
+ pushd html
+ dohtml -r *
+ popd
+ fi
+
+ doman doc/rake.1
+
+ newbashcomp "${FILESDIR}"/rake.bash-completion ${PN}
+}
diff --git a/dev-ruby/rake/rake-10.3.2.ebuild b/dev-ruby/rake/rake-10.3.2.ebuild
new file mode 100644
index 000000000000..daaa8accbeda
--- /dev/null
+++ b/dev-ruby/rake/rake-10.3.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.rdoc TODO"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit bash-completion-r1 ruby-fakegem
+
+DESCRIPTION="Make-like scripting in Ruby"
+HOMEPAGE="https://github.com/jimweirich/rake"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc"
+
+DEPEND+=" app-arch/gzip"
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-4:0 )"
+
+all_ruby_prepare() {
+ # Decompress the file. The compressed version has errors, ignore them.
+ zcat doc/rake.1.gz > doc/rake.1
+}
+
+all_ruby_compile() {
+ if use doc; then
+ rdoc --title "Rake - Ruby Make" --main README.rdoc --out html lib *.rdoc doc/*/*.rdoc || die
+ fi
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'gem "minitest", "~>4.0"; require "minitest/autorun"; Dir["test/test_*.rb"].each{|f| require f}' || die
+}
+
+all_ruby_install() {
+ ruby_fakegem_binwrapper rake
+
+ if use doc; then
+ pushd html
+ dohtml -r *
+ popd
+ fi
+
+ doman doc/rake.1
+
+ newbashcomp "${FILESDIR}"/rake.bash-completion ${PN}
+}
diff --git a/dev-ruby/rake/rake-10.4.0.ebuild b/dev-ruby/rake/rake-10.4.0.ebuild
new file mode 100644
index 000000000000..93f91da72540
--- /dev/null
+++ b/dev-ruby/rake/rake-10.4.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.rdoc TODO"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit bash-completion-r1 ruby-fakegem
+
+DESCRIPTION="Make-like scripting in Ruby"
+HOMEPAGE="https://github.com/jimweirich/rake"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc"
+
+DEPEND+=" app-arch/gzip"
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-5.4 )"
+
+all_ruby_prepare() {
+ # Decompress the file. The compressed version has errors, ignore them.
+ zcat doc/rake.1.gz > doc/rake.1
+}
+
+all_ruby_compile() {
+ if use doc; then
+ rdoc --title "Rake - Ruby Make" --main README.rdoc --out html lib *.rdoc doc/*/*.rdoc || die
+ fi
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'gem "minitest", "~>5.4"; require "minitest/autorun"; Dir["test/test_*.rb"].each{|f| require f}' || die
+}
+
+all_ruby_install() {
+ ruby_fakegem_binwrapper rake
+
+ if use doc; then
+ pushd html
+ dohtml -r *
+ popd
+ fi
+
+ doman doc/rake.1
+
+ newbashcomp "${FILESDIR}"/rake.bash-completion ${PN}
+}
diff --git a/dev-ruby/rake/rake-10.4.2.ebuild b/dev-ruby/rake/rake-10.4.2.ebuild
new file mode 100644
index 000000000000..fe54d2a7d4ba
--- /dev/null
+++ b/dev-ruby/rake/rake-10.4.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.rdoc TODO"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit bash-completion-r1 ruby-fakegem
+
+DESCRIPTION="Make-like scripting in Ruby"
+HOMEPAGE="https://github.com/jimweirich/rake"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc"
+
+DEPEND+=" app-arch/gzip"
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-5.4 )"
+
+all_ruby_compile() {
+ if use doc; then
+ rdoc --title "Rake - Ruby Make" --main README.rdoc --out html lib *.rdoc doc/*/*.rdoc || die
+ fi
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'gem "minitest", "~>5.4"; require "minitest/autorun"; Dir["test/test_*.rb"].each{|f| require f}' || die
+}
+
+all_ruby_install() {
+ ruby_fakegem_binwrapper rake
+
+ if use doc; then
+ pushd html
+ dohtml -r *
+ popd
+ fi
+
+ doman doc/rake.1
+
+ newbashcomp "${FILESDIR}"/rake.bash-completion ${PN}
+}