summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/rails-html-sanitizer
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/rails-html-sanitizer')
-rw-r--r--dev-ruby/rails-html-sanitizer/Manifest2
-rw-r--r--dev-ruby/rails-html-sanitizer/metadata.xml8
-rw-r--r--dev-ruby/rails-html-sanitizer/rails-html-sanitizer-1.0.1.ebuild30
-rw-r--r--dev-ruby/rails-html-sanitizer/rails-html-sanitizer-1.0.2.ebuild27
4 files changed, 67 insertions, 0 deletions
diff --git a/dev-ruby/rails-html-sanitizer/Manifest b/dev-ruby/rails-html-sanitizer/Manifest
new file mode 100644
index 000000000000..0cebbe9e5468
--- /dev/null
+++ b/dev-ruby/rails-html-sanitizer/Manifest
@@ -0,0 +1,2 @@
+DIST rails-html-sanitizer-1.0.1.gem 14848 SHA256 f8c08716c30a087d655ff99249a8cafd426344dc96d6647ee9015e4d06a08dee SHA512 05c4cbf5d49c6ed0c90bfe37bb10d1c12c69eb50170cb1bf8affddf3a02a12a2e043687fc541c4dd178c92040b3d3967bc643df759c699e325cead1a047b9f30 WHIRLPOOL 05a0b514e2896d6e845cc163b92632ba5a7aec995040c9a013aa8c74f7a4d1104f1ca953c2883b9f10e510c1dd289300aa9e5675528fa08daaa1e7d787fe4371
+DIST rails-html-sanitizer-1.0.2.gem 14848 SHA256 2481cfb60c4a03941489af5c92165c6dd169966f0b849d26d857cab5444b467a SHA512 c86b295ae42f9c78a32173fd80d659dd49b4938e6a8d8e170a709d692363aaa6159c7b77ca9a04ffff30a365934dc6e12437b58b2dc5ccbf44d30dbab4caecba WHIRLPOOL 65d1712339bc5a54d0207302badc5de8d000c65ba4d668ad777d4c63d89b5950ec6c3952f0e502a9b247a1762090994102c11840cf081bcf2b488c9829dc502c
diff --git a/dev-ruby/rails-html-sanitizer/metadata.xml b/dev-ruby/rails-html-sanitizer/metadata.xml
new file mode 100644
index 000000000000..74d503427bef
--- /dev/null
+++ b/dev-ruby/rails-html-sanitizer/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">rafaelfranca/rails-html-sanitizer</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rails-html-sanitizer/rails-html-sanitizer-1.0.1.ebuild b/dev-ruby/rails-html-sanitizer/rails-html-sanitizer-1.0.1.ebuild
new file mode 100644
index 000000000000..5bc28f85660b
--- /dev/null
+++ b/dev-ruby/rails-html-sanitizer/rails-html-sanitizer-1.0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Sanitize HTML fragments in Rails applications"
+HOMEPAGE="https://github.com/rafaelfranca/rails-html-sanitizer"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/loofah:0"
+
+all_ruby_prepare() {
+ # Avoid broken test already fixed in upstream master.
+ sed -i -e '/test_should_allow_anchors/askip "gentoo"' test/sanitizer_test.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'Dir["test/*_test.rb"].each{|f| require f}' || die
+}
diff --git a/dev-ruby/rails-html-sanitizer/rails-html-sanitizer-1.0.2.ebuild b/dev-ruby/rails-html-sanitizer/rails-html-sanitizer-1.0.2.ebuild
new file mode 100644
index 000000000000..081f5daae292
--- /dev/null
+++ b/dev-ruby/rails-html-sanitizer/rails-html-sanitizer-1.0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Sanitize HTML fragments in Rails applications"
+HOMEPAGE="https://github.com/rafaelfranca/rails-html-sanitizer"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/loofah:0"
+
+ruby_add_bdepend "test? ( dev-ruby/rails-dom-testing )"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'Dir["test/*_test.rb"].each{|f| require f}' || die
+}