summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/ragol
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/ragol')
-rw-r--r--dev-ruby/ragol/Manifest1
-rw-r--r--dev-ruby/ragol/metadata.xml8
-rw-r--r--dev-ruby/ragol/ragol-1.0.1-r1.ebuild25
-rw-r--r--dev-ruby/ragol/ragol-1.0.1-r2.ebuild25
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-ruby/ragol/Manifest b/dev-ruby/ragol/Manifest
new file mode 100644
index 000000000000..85d4acbb6bc0
--- /dev/null
+++ b/dev-ruby/ragol/Manifest
@@ -0,0 +1 @@
+DIST ragol-git-1.0.1.tgz 18748 SHA256 295e55e7435daf4ad0b704422c076a6033dad0d37976b1ccdf4b52e2771b6621 SHA512 97002cf899a38dcc52f17c47efa6c8cdeab602be19910108e8efa7097a04ed86783ba4389d5f11c84179ec085aa9bfcb8f506dd42904ce0517bc5957ea414de6 WHIRLPOOL bc50852f2a4873d378539c7f2fe2d7de5247798fe926a07f16c2796d4d144dc7426c915ad64d1500068ad7b9ced2e8616c0434614a48af7aa033b8b2d9cb40a9
diff --git a/dev-ruby/ragol/metadata.xml b/dev-ruby/ragol/metadata.xml
new file mode 100644
index 000000000000..a56adbd92e03
--- /dev/null
+++ b/dev-ruby/ragol/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">jpace/ragol</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/ragol/ragol-1.0.1-r1.ebuild b/dev-ruby/ragol/ragol-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..6eec81898c5b
--- /dev/null
+++ b/dev-ruby/ragol/ragol-1.0.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="Features.txt History.txt NEWS README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Another implementation of an option processor"
+HOMEPAGE="https://github.com/jpace/ragol"
+
+SRC_URI="https://github.com/jpace/ragol/archive/v${PV}.tar.gz -> ${PN}-git-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 hppa ~ppc ~sparc x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/logue-1.0.0"
diff --git a/dev-ruby/ragol/ragol-1.0.1-r2.ebuild b/dev-ruby/ragol/ragol-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..3d9e5563dabe
--- /dev/null
+++ b/dev-ruby/ragol/ragol-1.0.1-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="Features.txt History.txt NEWS README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Another implementation of an option processor"
+HOMEPAGE="https://github.com/jpace/ragol"
+
+SRC_URI="https://github.com/jpace/ragol/archive/v${PV}.tar.gz -> ${PN}-git-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/logue-1.0.0"