summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-30 19:14:56 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-30 19:15:15 -0500
commita3fd1df4463cdfb075fb8873c245a57af7c060e6 (patch)
tree11cd6d8110783edd80b043c69c1739dff9c4dd63 /dev-ruby/puppetdb-termini
parentapp-admin/puppetdb: 6.3.2 bump (diff)
downloadgentoo-a3fd1df4463cdfb075fb8873c245a57af7c060e6.tar.gz
gentoo-a3fd1df4463cdfb075fb8873c245a57af7c060e6.tar.bz2
gentoo-a3fd1df4463cdfb075fb8873c245a57af7c060e6.zip
dev-ruby/puppetdb-termini: 6.3.2 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-ruby/puppetdb-termini')
-rw-r--r--dev-ruby/puppetdb-termini/Manifest1
-rw-r--r--dev-ruby/puppetdb-termini/puppetdb-termini-6.3.2.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/puppetdb-termini/Manifest b/dev-ruby/puppetdb-termini/Manifest
index 03b240b06cf4..09b26bbf4c58 100644
--- a/dev-ruby/puppetdb-termini/Manifest
+++ b/dev-ruby/puppetdb-termini/Manifest
@@ -2,3 +2,4 @@ DIST puppetdb-termini_5.2.4-1xenial_all.deb 20538 BLAKE2B aad000bc0e13e3c97f4428
DIST puppetdb-termini_5.2.7-1xenial_all.deb 20560 BLAKE2B def7bb25badadd2880589d5708e8b9a0f87033977a21ee65fca7b27caf8c3568c66cf7f21123ecd8dd037e29023e65a9393d8b3608ffe0e021f9aad5a8c66755 SHA512 b5a5b4c721a35d95093d9da757f5a2dcfcc232343b6ca6dcf7184a20f9ff305a9c2f04328e17a0e02579d6ee7245c7c9b7e9ba8d22bc8f3bc1c13cf50c784101
DIST puppetdb-termini_6.2.0-1stretch_all.deb 20602 BLAKE2B 6f51e8f6d87df992ced0ccc23c1cecd26a1fd2b3ad2b1d507b22d3f555fafd754913f50aa7840f40cb8c3cdcabfd4af84411213842d4a70105c69d9a8fe55eaf SHA512 ec73ee1514d6217e57672936d775974911bee7135af95d95e58f60c723d8e8760b005cb2a214fdfe692acd807e07ae53ba396bcf5f990c77d9a07ca485a784c1
DIST puppetdb-termini_6.3.1-1stretch_all.deb 20680 BLAKE2B d4c8329b61805730aa7ac5a2da32670f5cb5e3597b3213535c5fbf26615aed847420b2f2589d34bcffc61a454319ea59e43dc61189254844952a7e79ac020971 SHA512 97d11b5ca7e0dc6502d32d8f0d299880b9cdaced4bafef38d8bbc22e0b4c154c8c414e19d715b53c0d42bd511aad3e2e2f0a265dcaf2767f3950e16ed2adfef7
+DIST puppetdb-termini_6.3.2-1stretch_all.deb 20662 BLAKE2B 2e7daef3892070d5356ced070544099a546e4887b5654f795e06952862e4c0cb155df200806217fd5376b1bc3fb53107467ca76acec05283d2f25fed7ca7e5ca SHA512 555abacc9de7221df78a8459a76a4c3c8ce3a1bf5e2b6f1d800761eaea650d2a308e6a5054be082cfb9823903fbe049b2dc5f323b8af93693afbb61c8ce6c4be
diff --git a/dev-ruby/puppetdb-termini/puppetdb-termini-6.3.2.ebuild b/dev-ruby/puppetdb-termini/puppetdb-termini-6.3.2.ebuild
new file mode 100644
index 000000000000..6d51b944dfdb
--- /dev/null
+++ b/dev-ruby/puppetdb-termini/puppetdb-termini-6.3.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+inherit unpacker
+
+DESCRIPTION="Library needed to connect puppet to puppetdb"
+HOMEPAGE="http://docs.puppetlabs.com/puppetdb/"
+SRC_URI="http://apt.puppetlabs.com/pool/stretch/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1stretch_all.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+# will need the same keywords as puppet
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND+=""
+DEPEND+=""
+
+S=${WORKDIR}
+
+src_install() {
+ insinto opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/
+ doins -r opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/*
+}