summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-10-06 07:13:01 +0200
committerHans de Graaff <graaff@gentoo.org>2017-10-06 07:13:01 +0200
commit45e01ece70ab3fe49faa30eae149e1bd9f323836 (patch)
tree4805c907971369893351611cb08a9f1d07e934d4 /dev-ruby/pathutil/pathutil-0.16.0.ebuild
parentnet-wireless/kismet: drop unused lines in stable ebuild to quiet repoman (diff)
downloadgentoo-45e01ece70ab3fe49faa30eae149e1bd9f323836.tar.gz
gentoo-45e01ece70ab3fe49faa30eae149e1bd9f323836.tar.bz2
gentoo-45e01ece70ab3fe49faa30eae149e1bd9f323836.zip
dev-ruby/pathutil: add 0.16.0
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-ruby/pathutil/pathutil-0.16.0.ebuild')
-rw-r--r--dev-ruby/pathutil/pathutil-0.16.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/pathutil/pathutil-0.16.0.ebuild b/dev-ruby/pathutil/pathutil-0.16.0.ebuild
new file mode 100644
index 000000000000..d6583688b0e3
--- /dev/null
+++ b/dev-ruby/pathutil/pathutil-0.16.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="Gem.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Like Pathname but a little less insane"
+HOMEPAGE="https://rubygems.org/gems/pathutil https://github.com/envygeeks/pathutils"
+SRC_URI="https://github.com/envygeeks/pathutil/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/forwardable-extended-2.6
+ <dev-ruby/forwardable-extended-3"
+
+all_ruby_prepare() {
+ sed -i -e '/\(coverage\|luna\|rspec\/helpers\)/ s:^:#:' \
+ -e '1irequire "pathname"; require "tempfile"; require "tmpdir"; require "json"' \
+ spec/rspec/helper.rb || die
+ rm -f spec/support/coverage.rb || die
+}