summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-11-27 08:41:01 +0100
committerHans de Graaff <graaff@gentoo.org>2022-11-28 08:01:00 +0100
commitccd444927a63786ed1f4a6101c447714d571ba9d (patch)
treed93d6bb80345e7215d750d7529a2bdf48c7d3a2e /dev-ruby/jmespath
parentmedia-sound/qtractor: Stabilize 0.9.29 x86, #883247 (diff)
downloadgentoo-ccd444927a63786ed1f4a6101c447714d571ba9d.tar.gz
gentoo-ccd444927a63786ed1f4a6101c447714d571ba9d.tar.bz2
gentoo-ccd444927a63786ed1f4a6101c447714d571ba9d.zip
dev-ruby/jmespath: add 1.6.2
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/jmespath')
-rw-r--r--dev-ruby/jmespath/Manifest1
-rw-r--r--dev-ruby/jmespath/jmespath-1.6.2.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/jmespath/Manifest b/dev-ruby/jmespath/Manifest
index 1ebc44c75643..1f3fe455bc96 100644
--- a/dev-ruby/jmespath/Manifest
+++ b/dev-ruby/jmespath/Manifest
@@ -1 +1,2 @@
DIST jmespath-1.6.1.tar.gz 40731 BLAKE2B 004da1c19a9990f83cc7484afccf7f7c8b6924ff538a0779752a4fd2aa0d469fd7ddf975f39e50f3f3d806109d6742adbc16237dec5760c224a59e6791954529 SHA512 8c66235463f1d83a2b061e9e01b5ef0d3d12df5a034a334d3c06a919bc2049b44dd740da0297e1774300533bc9968614f3d961deb4bfe808c9221e03d6f1bbed
+DIST jmespath-1.6.2.tar.gz 40932 BLAKE2B e19a2bacb8e207f65e45d1ad8eaaceb5ab6cbd847dc1009b45c618d426e5cc5814a1b1a806ccd935a83e3dacff3bcefedf9c7241586a348f2b705d80e63ba27d SHA512 2118c348bb25285f002fce64d0f7a00a5850c9f1b39d71d16c0c4335469069861bc51a81a9aec95f5625ae6b2d9daaa8b40ada817ac83ef83349c33e906561e7
diff --git a/dev-ruby/jmespath/jmespath-1.6.2.ebuild b/dev-ruby/jmespath/jmespath-1.6.2.ebuild
new file mode 100644
index 000000000000..c3f5e802faf7
--- /dev/null
+++ b/dev-ruby/jmespath/jmespath-1.6.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRAINSTALL="VERSION"
+RUBY_FAKEGEM_GEMSPEC="jmespath.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements JMESPath for Ruby"
+HOMEPAGE="https://github.com/jmespath/jmespath.rb"
+SRC_URI="https://github.com/jmespath/jmespath.rb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="${PN}.rb-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~amd64 ~arm64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/I s:^:#:' \
+ spec/{compliance_spec,compliance_without_errors_spec,spec_helper}.rb || die
+ sed -i -e '/bundler/I s:^:#:' spec/spec_helper.rb || die
+}