summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/charlock_holmes
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/charlock_holmes')
-rw-r--r--dev-ruby/charlock_holmes/Manifest1
-rw-r--r--dev-ruby/charlock_holmes/charlock_holmes-0.7.3.ebuild47
-rw-r--r--dev-ruby/charlock_holmes/metadata.xml8
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-ruby/charlock_holmes/Manifest b/dev-ruby/charlock_holmes/Manifest
new file mode 100644
index 000000000000..599cd2e09a16
--- /dev/null
+++ b/dev-ruby/charlock_holmes/Manifest
@@ -0,0 +1 @@
+DIST charlock_holmes-0.7.3.gem 1196544 SHA256 c7d15154b442e393adbcd838f6e3b620a7fbe07197a7cd57d7ba4a7ec434544b SHA512 29e173f5ce870c16fd1af2e38b9aa2cada4b8ddae534933f18c82b719ae65b8fac82434ed87696b435b7236e180c06c9ccaa16c742dff5f8b1fd87da48894027 WHIRLPOOL 48c964c1ae89f9f88939dbcc3ed8bfdf80677a7c1b2eabf1514f7ed7a95fd92b03cc05f079e8844e5df5d24d7d306a85306721e39fa2352c185175c6fe1422d9
diff --git a/dev-ruby/charlock_holmes/charlock_holmes-0.7.3.ebuild b/dev-ruby/charlock_holmes/charlock_holmes-0.7.3.ebuild
new file mode 100644
index 000000000000..049f1699c912
--- /dev/null
+++ b/dev-ruby/charlock_holmes/charlock_holmes-0.7.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Character encoding detecting library for Ruby using ICU"
+HOMEPAGE="http://github.com/brianmario/charlock_holmes"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_bdepend "test? (
+ dev-ruby/minitest )"
+
+CDEPEND="dev-libs/icu:=
+ sys-libs/zlib"
+DEPEND+=" ${CDEPEND}"
+RDEPEND+=" ${CDEPEND}"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/d' test/helper.rb || die
+
+ # Avoid dependency on rake-compiler
+ sed -i -e '/rake-compiler/,$ s:^:#:' Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/${PN} extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/${PN}
+ cp ext/${PN}/${PN}$(get_modname) lib/${PN}/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/*.rb || die
+}
diff --git a/dev-ruby/charlock_holmes/metadata.xml b/dev-ruby/charlock_holmes/metadata.xml
new file mode 100644
index 000000000000..026dbd9ea0f3
--- /dev/null
+++ b/dev-ruby/charlock_holmes/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">brianmario/charlock_holmes</remote-id>
+ </upstream>
+</pkgmetadata>