summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/camping
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/camping')
-rw-r--r--dev-ruby/camping/Manifest1
-rw-r--r--dev-ruby/camping/camping-2.1.532.ebuild33
-rw-r--r--dev-ruby/camping/metadata.xml5
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/camping/Manifest b/dev-ruby/camping/Manifest
new file mode 100644
index 000000000000..d29875544234
--- /dev/null
+++ b/dev-ruby/camping/Manifest
@@ -0,0 +1 @@
+DIST camping-2.1.532.gem 375808 SHA256 ee36aa39e61a7aeb3d7b6973f7c88a5e4eecd2a52b7e8f1668d4be7b522f4ae0 SHA512 0a061ed886b7bb86bfe0906e8a7950b96d2c8360bde3c0545b52d41b3012b1c3975a056449f1919c8ba454ee6457738bfc9f815da8ce764e79ef3cf9981e9408 WHIRLPOOL feb71664b586a7e77816aef965daf11efd1612cebf7bcbcb607670a3821e97b674f3926663054108533c07353642cf3facf53085576c3ae8a831a05fd528e418
diff --git a/dev-ruby/camping/camping-2.1.532.ebuild b/dev-ruby/camping/camping-2.1.532.ebuild
new file mode 100644
index 000000000000..d2ead733e451
--- /dev/null
+++ b/dev-ruby/camping/camping-2.1.532.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A small web framework modeled after Ruby on Rails"
+HOMEPAGE="http://wiki.github.com/camping/camping"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/rack-test >=dev-ruby/minitest-4:0 dev-ruby/tilt:0 )"
+
+ruby_add_rdepend "
+ >=dev-ruby/mab-0.0.3
+ >=dev-ruby/rack-1.0:*"
+
+all_ruby_prepare() {
+ sed -i -e '1igem "minitest", "~> 4.0"; gem "tilt", "~>1.0"' test/test_helper.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S testrb test/app_*.rb || die
+}
diff --git a/dev-ruby/camping/metadata.xml b/dev-ruby/camping/metadata.xml
new file mode 100644
index 000000000000..ed77b4f90bcb
--- /dev/null
+++ b/dev-ruby/camping/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+</pkgmetadata>