summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-08-04 08:13:43 +0200
committerHans de Graaff <graaff@gentoo.org>2017-08-04 08:17:27 +0200
commitb1492560f48e81c921282dbc69bdeb3cef32c0c9 (patch)
tree30add03b7ebcb437ed333b13dd85c6c025a9f23e /dev-ruby/activejob/activejob-5.0.5.ebuild
parentdev-ruby/actioncable: add rails 5.0.5 (diff)
downloadgentoo-b1492560f48e81c921282dbc69bdeb3cef32c0c9.tar.gz
gentoo-b1492560f48e81c921282dbc69bdeb3cef32c0c9.tar.bz2
gentoo-b1492560f48e81c921282dbc69bdeb3cef32c0c9.zip
dev-ruby/activejob: add rails 5.0.5
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ruby/activejob/activejob-5.0.5.ebuild')
-rw-r--r--dev-ruby/activejob/activejob-5.0.5.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/activejob/activejob-5.0.5.ebuild b/dev-ruby/activejob/activejob-5.0.5.ebuild
new file mode 100644
index 000000000000..781247b37b01
--- /dev/null
+++ b/dev-ruby/activejob/activejob-5.0.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Job framework with pluggable queues"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~amd64-linux"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/globalid-0.3.6
+"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.14.0:0.14
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ sed -i -e '1igem "activesupport", "~>5.0.0"' test/helper.rb || die
+
+ # Remove all currently unpackaged queues.
+ sed -i -e 's/delayed_job que queue_classic resque sidekiq sneakers sucker_punch backburner//' Rakefile || die
+}