summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/RubyInline
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/RubyInline')
-rw-r--r--dev-ruby/RubyInline/Manifest3
-rw-r--r--dev-ruby/RubyInline/RubyInline-3.12.2.ebuild46
-rw-r--r--dev-ruby/RubyInline/RubyInline-3.12.3-r1.ebuild47
-rw-r--r--dev-ruby/RubyInline/RubyInline-3.12.3.ebuild46
-rw-r--r--dev-ruby/RubyInline/RubyInline-3.12.4.ebuild47
-rw-r--r--dev-ruby/RubyInline/files/ruby-inline-3.11.1-ldflags.patch10
-rw-r--r--dev-ruby/RubyInline/files/ruby-inline-3.12.2-gentoo.patch67
-rw-r--r--dev-ruby/RubyInline/metadata.xml5
8 files changed, 271 insertions, 0 deletions
diff --git a/dev-ruby/RubyInline/Manifest b/dev-ruby/RubyInline/Manifest
new file mode 100644
index 000000000000..e5f117e63873
--- /dev/null
+++ b/dev-ruby/RubyInline/Manifest
@@ -0,0 +1,3 @@
+DIST RubyInline-3.12.2.gem 29184 SHA256 28506b5ab38faae32d8a242483996b197ed4e5cf0419652072af446c0a3fe971 SHA512 cef52a9a624bcae92f5231ba3d4e5809c186221a89a445409b0096e59712ea90f66568b6682731dfa8228b0c8441ed6cde86a6d80319c6b0d6698abb05252384 WHIRLPOOL 1dd9ed15e71013be5ad9fcb291324a8f42933d11f8be80c6e0f2a84ed0c02e877491612554b3b6de2236555439ce82e9360e86426723129d1bec06404069eb24
+DIST RubyInline-3.12.3.gem 31232 SHA256 c1ececb4057d22638818c1bf1998cdbe485bf6eda81c3fe52a543487c9c35ad6 SHA512 26b852abe21b077deca6206bac3a29e402e37b9bd96997275a8075172fee34d25e68b9455a933188bb71807e3fe2a35bf15350f568ba3786034796bc5a33f7cf WHIRLPOOL b42ba1f45206758d1dc50990c9be3b4167a40771f09eaeb352fbd2038515979fd307983d37c3a5aa4a1b32edc114aa5ed229e7573e387c112e54cb45fd5f5e16
+DIST RubyInline-3.12.4.gem 31232 SHA256 205bbc14c02d3d55e1b497241ede832ab87f3d981f92f3bda98b75e8144103e0 SHA512 9bdef81653a6c8da86aac638ff402b226526fbd38b9b8538382ac2d1a7655e232eafff4979b57d667ad9b0f3955b13c6f4cc01eb9dfa287c3a7abbfc5e9416fe WHIRLPOOL 5b92ecde15ee188d5d1ef51c83327e96486527680b33e3b4d0b4057df6804c8e566748e14d656a9ae62c6d549b462b148776a3f92707c456c28a8820f4410c1e
diff --git a/dev-ruby/RubyInline/RubyInline-3.12.2.ebuild b/dev-ruby/RubyInline/RubyInline-3.12.2.ebuild
new file mode 100644
index 000000000000..d47c154c16fe
--- /dev/null
+++ b/dev-ruby/RubyInline/RubyInline-3.12.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Allows to embed C/C++ in Ruby code"
+HOMEPAGE="http://www.zenspider.com/ZSS/Products/RubyInline/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_rdepend dev-ruby/zentest
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/hoe
+ dev-ruby/hoe-seattlerb
+ virtual/ruby-minitest
+ )"
+
+RUBY_PATCHES=(
+ ruby-inline-3.12.2-gentoo.patch
+ ruby-inline-3.11.1-ldflags.patch
+)
+
+all_ruby_prepare() {
+ sed -i -e '/isolate/ s:^:#:' Rakefile || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc example.rb example2.rb demo/*.rb
+}
diff --git a/dev-ruby/RubyInline/RubyInline-3.12.3-r1.ebuild b/dev-ruby/RubyInline/RubyInline-3.12.3-r1.ebuild
new file mode 100644
index 000000000000..fefe01b69ea8
--- /dev/null
+++ b/dev-ruby/RubyInline/RubyInline-3.12.3-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ruby22 -> Code uses obsolete Config module.
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Allows to embed C/C++ in Ruby code"
+HOMEPAGE="http://www.zenspider.com/ZSS/Products/RubyInline/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_rdepend "dev-ruby/zentest"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/hoe-3
+ dev-ruby/hoe-seattlerb
+ dev-ruby/minitest:5
+ )"
+
+RUBY_PATCHES=(
+ ruby-inline-3.12.2-gentoo.patch
+ ruby-inline-3.11.1-ldflags.patch
+)
+
+all_ruby_prepare() {
+ sed -i -e '/isolate/ s:^:#:' Rakefile || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc example.rb example2.rb demo/*.rb
+}
diff --git a/dev-ruby/RubyInline/RubyInline-3.12.3.ebuild b/dev-ruby/RubyInline/RubyInline-3.12.3.ebuild
new file mode 100644
index 000000000000..4f78fe192a7f
--- /dev/null
+++ b/dev-ruby/RubyInline/RubyInline-3.12.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Allows to embed C/C++ in Ruby code"
+HOMEPAGE="http://www.zenspider.com/ZSS/Products/RubyInline/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ~hppa ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_rdepend "dev-ruby/zentest"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/hoe
+ dev-ruby/hoe-seattlerb
+ virtual/ruby-minitest
+ )"
+
+RUBY_PATCHES=(
+ ruby-inline-3.12.2-gentoo.patch
+ ruby-inline-3.11.1-ldflags.patch
+)
+
+all_ruby_prepare() {
+ sed -i -e '/isolate/ s:^:#:' Rakefile || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc example.rb example2.rb demo/*.rb
+}
diff --git a/dev-ruby/RubyInline/RubyInline-3.12.4.ebuild b/dev-ruby/RubyInline/RubyInline-3.12.4.ebuild
new file mode 100644
index 000000000000..fefe01b69ea8
--- /dev/null
+++ b/dev-ruby/RubyInline/RubyInline-3.12.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ruby22 -> Code uses obsolete Config module.
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Allows to embed C/C++ in Ruby code"
+HOMEPAGE="http://www.zenspider.com/ZSS/Products/RubyInline/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_rdepend "dev-ruby/zentest"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/hoe-3
+ dev-ruby/hoe-seattlerb
+ dev-ruby/minitest:5
+ )"
+
+RUBY_PATCHES=(
+ ruby-inline-3.12.2-gentoo.patch
+ ruby-inline-3.11.1-ldflags.patch
+)
+
+all_ruby_prepare() {
+ sed -i -e '/isolate/ s:^:#:' Rakefile || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc example.rb example2.rb demo/*.rb
+}
diff --git a/dev-ruby/RubyInline/files/ruby-inline-3.11.1-ldflags.patch b/dev-ruby/RubyInline/files/ruby-inline-3.11.1-ldflags.patch
new file mode 100644
index 000000000000..e6856ac5a0d7
--- /dev/null
+++ b/dev-ruby/RubyInline/files/ruby-inline-3.11.1-ldflags.patch
@@ -0,0 +1,10 @@
+--- lib/inline.rb.~1~ 2010-08-28 14:49:06.866480357 +0200
++++ lib/inline.rb 2010-08-28 15:05:14.553732182 +0200
+@@ -577,6 +577,7 @@
+ "-L#{Config::CONFIG['libdir']}",
+ '-o', so_name.inspect,
+ File.expand_path(src_name).inspect,
++ Config::CONFIG['LIBRUBYARG_SHARED'],
+ libs,
+ crap_for_windoze ].join(' ')
+
diff --git a/dev-ruby/RubyInline/files/ruby-inline-3.12.2-gentoo.patch b/dev-ruby/RubyInline/files/ruby-inline-3.12.2-gentoo.patch
new file mode 100644
index 000000000000..2acd527cdcb4
--- /dev/null
+++ b/dev-ruby/RubyInline/files/ruby-inline-3.12.2-gentoo.patch
@@ -0,0 +1,67 @@
+we have to patch the code so that it takes the RUBY_DESCRIPTION into
+consideration, to avoid loading Ruby-Enterprise (REE18) objects in MRI
+and vice-versa; we're a bit “greedier” since we will rebuild objects
+even when just switching versions, but it'll be better this way than
+being too conservatives.
+
+Index: ruby-inline-3.8.4/lib/inline.rb
+===================================================================
+--- ruby-inline-3.8.4.orig/lib/inline.rb
++++ ruby-inline-3.8.4/lib/inline.rb
+@@ -360,13 +360,18 @@ module Inline
+ ext.join "\n"
+ end
+
++ def implementation_checksum
++ @implementation_checksum ||=
++ (Digest::MD5.new << RUBY_DESCRIPTION).to_s[0,4]
++ end
++
+ def module_name
+ unless defined? @module_name then
+ module_name = @mod.name.gsub('::','__')
+ md5 = Digest::MD5.new
+ @pre.each { |m| md5 << m.to_s }
+ @sig.keys.sort_by { |x| x.to_s }.each { |m| md5 << m.to_s }
+- @module_name = "Inline_#{module_name}_#{md5}"
++ @module_name = "Inline_#{module_name}_#{md5}_#{implementation_checksum}"
+ end
+ @module_name
+ end
+Index: ruby-inline-3.8.4/test/test_inline.rb
+===================================================================
+--- ruby-inline-3.8.4.orig/test/test_inline.rb
++++ ruby-inline-3.8.4/test/test_inline.rb
+@@ -404,6 +404,7 @@ static VALUE method_name_equals(VALUE se
+ end
+
+ def util_module_name(*signatures)
++ implementation = (Digest::MD5.new << RUBY_DESCRIPTION).to_s[0,4]
+ md5 = Digest::MD5.new
+
+ signatures.each do |signature|
+@@ -411,6 +412,6 @@ static VALUE method_name_equals(VALUE se
+ md5 << signature.to_s
+ end
+
+- assert_equal("Inline_TestInline__TestC_#{md5}", @builder.module_name)
++ assert_equal("Inline_TestInline__TestC_#{md5}_#{implementation}", @builder.module_name)
+ end
+
+@@ -757,6 +758,7 @@ puts(s); return rb_str_new2(s)}"
+ @builder.c "VALUE my_method() { return Qnil; }"
+
+ windoze = "\n __declspec(dllexport)" if Inline::WINDOZE
++ implementation = (Digest::MD5.new << RUBY_DESCRIPTION).to_s[0,4]
+
+ expected = <<-EXT
+ #include "ruby.h"
+@@ -773,7 +775,7 @@ static VALUE my_method(VALUE self) {
+ #ifdef __cplusplus
+ extern \"C\" {
+ #endif#{windoze}
+- void Init_Inline_TestInline__TestC_3ab8c09639e499394bb1f0a0194a839f() {
++ void Init_Inline_TestInline__TestC_3ab8c09639e499394bb1f0a0194a839f_#{implementation}() {
+ VALUE c = rb_cObject;
+ c = rb_const_get(c, rb_intern("TestInline"));
+ c = rb_const_get(c, rb_intern("TestC"));
diff --git a/dev-ruby/RubyInline/metadata.xml b/dev-ruby/RubyInline/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/RubyInline/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>