summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-07-12 07:21:24 +0200
committerHans de Graaff <graaff@gentoo.org>2023-07-12 07:41:20 +0200
commit84ca8780f0cb3ed63170e7a5ed4a818bd6fdd5a5 (patch)
treee891e6a33dc04731821a051ab7ad0b01b63be81b /dev-ruby/GeoRuby
parentdev-ruby/git: drop 1.13.2, 1.16.0 (diff)
downloadgentoo-84ca8780f0cb3ed63170e7a5ed4a818bd6fdd5a5.tar.gz
gentoo-84ca8780f0cb3ed63170e7a5ed4a818bd6fdd5a5.tar.bz2
gentoo-84ca8780f0cb3ed63170e7a5ed4a818bd6fdd5a5.zip
dev-ruby/GeoRuby: update EAPI 7 -> 8
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/GeoRuby')
-rw-r--r--dev-ruby/GeoRuby/GeoRuby-2.5.2-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/GeoRuby/GeoRuby-2.5.2-r2.ebuild b/dev-ruby/GeoRuby/GeoRuby-2.5.2-r2.ebuild
new file mode 100644
index 000000000000..c49df03ad9f2
--- /dev/null
+++ b/dev-ruby/GeoRuby/GeoRuby-2.5.2-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_NAME="georuby"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby data holder for OGC Simple Features"
+HOMEPAGE="https://github.com/nofxx/georuby"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # Avoid specs that are also failing in upstream Travis.
+ rm spec/geo_ruby/shp4r/shp_spec.rb || die
+}
+
+ruby_add_bdepend "test? ( dev-ruby/dbf
+ dev-ruby/nokogiri )"