summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-08-28 18:31:51 +0200
committerAlexis Ballier <aballier@gentoo.org>2019-08-28 19:01:45 +0200
commitcd6af72137f80578bb6d5c1863e168f779488f08 (patch)
tree71bc1993c9879ee16ac6ad4c738661aa441398aa /dev-ros
parentdev-ros/image_view: Remove old (diff)
downloadgentoo-cd6af72137f80578bb6d5c1863e168f779488f08.tar.gz
gentoo-cd6af72137f80578bb6d5c1863e168f779488f08.tar.bz2
gentoo-cd6af72137f80578bb6d5c1863e168f779488f08.zip
dev-ros/image_view: fix build with boost 1.70
Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/image_view/files/boost170.patch13
-rw-r--r--dev-ros/image_view/image_view-1.12.23.ebuild3
2 files changed, 15 insertions, 1 deletions
diff --git a/dev-ros/image_view/files/boost170.patch b/dev-ros/image_view/files/boost170.patch
new file mode 100644
index 000000000000..ab52d89c5fad
--- /dev/null
+++ b/dev-ros/image_view/files/boost170.patch
@@ -0,0 +1,13 @@
+Index: image_view/CMakeLists.txt
+===================================================================
+--- image_view.orig/CMakeLists.txt
++++ image_view/CMakeLists.txt
+@@ -5,7 +5,7 @@ find_package(catkin REQUIRED COMPONENTS
+ generate_dynamic_reconfigure_options(cfg/ImageView.cfg)
+
+ catkin_package(CATKIN_DEPENDS dynamic_reconfigure)
+-find_package(Boost REQUIRED COMPONENTS signals thread)
++find_package(Boost REQUIRED COMPONENTS thread)
+ find_package(OpenCV REQUIRED)
+
+ include_directories(${Boost_INCLUDE_DIRS}
diff --git a/dev-ros/image_view/image_view-1.12.23.ebuild b/dev-ros/image_view/image_view-1.12.23.ebuild
index 6835689f080e..ef3403e53429 100644
--- a/dev-ros/image_view/image_view-1.12.23.ebuild
+++ b/dev-ros/image_view/image_view-1.12.23.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -31,3 +31,4 @@ RDEPEND="
dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/boost170.patch" )