summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-06-08 14:14:49 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-06-08 14:26:28 +0200
commit48ea473ba0837c78958a6fcde4ed80385fd45a34 (patch)
tree52b638eab5ce36b44fd0d47d3ed81b535a65b9eb /dev-ros
parentros-meta/roscpp_core: Bump to 0.6.11. (diff)
downloadgentoo-48ea473ba0837c78958a6fcde4ed80385fd45a34.tar.gz
gentoo-48ea473ba0837c78958a6fcde4ed80385fd45a34.tar.bz2
gentoo-48ea473ba0837c78958a6fcde4ed80385fd45a34.zip
dev-ros/imu_complementary_filter: Bump to 1.2.0.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/imu_complementary_filter/Manifest1
-rw-r--r--dev-ros/imu_complementary_filter/imu_complementary_filter-1.2.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/imu_complementary_filter/Manifest b/dev-ros/imu_complementary_filter/Manifest
index 5c6576ba8015..f88e2c915d89 100644
--- a/dev-ros/imu_complementary_filter/Manifest
+++ b/dev-ros/imu_complementary_filter/Manifest
@@ -1 +1,2 @@
DIST imu_tools-1.1.5.tar.gz 1653083 BLAKE2B 8c0e84333455a5b4cae215a2e54b74ff828d00a426b9ab13f4048a72556b6a526dc4256a53dc3e21e098cc31ea6d21e0d508066a4627d01c27681ce0b3b18035 SHA512 5009884852c71d6bb1b6c2be2f30ed333eca2ac6a7f29d02cb8f0821c0b95a33dd3b09049c4c4eeb1416fb0eb5dc454b3c6d36c2c24303f37c0d1d2c0c2d906a
+DIST imu_tools-1.2.0.tar.gz 1653607 BLAKE2B 76cccfeae657188e3be3774bcb19c5edac94e7070a6fd8a01c8a56857297491568f978820e6f32467b031ceece4742e6c0fe926e5d59ad19a2f6fb1c037ac3ec SHA512 3f39a2ec539949a6881cc106122d663706ddd3ed03ed822b9370e56beb56f1349bfd668a71e443ab2b9d525c6a3a88fad053768764160d9d0f04c08ba1ad2f8e
diff --git a/dev-ros/imu_complementary_filter/imu_complementary_filter-1.2.0.ebuild b/dev-ros/imu_complementary_filter/imu_complementary_filter-1.2.0.ebuild
new file mode 100644
index 000000000000..bbbf6e05dd1b
--- /dev/null
+++ b/dev-ros/imu_complementary_filter/imu_complementary_filter-1.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ccny-ros-pkg/imu_tools"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Fuses angular velocities, accelerations, and (optionally) magnetic readings from an IMU device"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/message_filters
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules
+"