summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-08-28 19:27:47 +0200
committerAlexis Ballier <aballier@gentoo.org>2019-08-29 17:50:29 +0200
commitca23c3d553e4df3371ca7e33c0d0ce23be964936 (patch)
tree36c814f14f342a071f1abca7c2dfcfeb2ed9f56e /dev-ros/visp_hand2eye_calibration
parentdev-ros/visp_camera_calibration: Bump to 0.11.1. (diff)
downloadgentoo-ca23c3d553e4df3371ca7e33c0d0ce23be964936.tar.gz
gentoo-ca23c3d553e4df3371ca7e33c0d0ce23be964936.tar.bz2
gentoo-ca23c3d553e4df3371ca7e33c0d0ce23be964936.zip
dev-ros/visp_hand2eye_calibration: Bump to 0.11.1.
Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/visp_hand2eye_calibration')
-rw-r--r--dev-ros/visp_hand2eye_calibration/Manifest1
-rw-r--r--dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-0.11.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/visp_hand2eye_calibration/Manifest b/dev-ros/visp_hand2eye_calibration/Manifest
index 879345d3f523..c32832af2d0d 100644
--- a/dev-ros/visp_hand2eye_calibration/Manifest
+++ b/dev-ros/visp_hand2eye_calibration/Manifest
@@ -1 +1,2 @@
DIST vision_visp-0.10.0.tar.gz 1015180 BLAKE2B bf0474d0633a6b704077e232d4676e6ebb9ec666b9b03792dbb929c6c6d1c52a941f7a4517f7bc6a7150882c16ba719eb3cf17c3fbdd13df109eab3a34afa259 SHA512 8e2652d6ca9c9535f1bebb628ec908f64c9fc89358bc92ed42ef12430b0b28c8ed3ed7935d2d3fe03c9761f9ac08e200eb59839ee2243df62d5934e8162cca9c
+DIST vision_visp-0.11.1.tar.gz 1014349 BLAKE2B 63148bef65a8361be7cb4a3d27bae4e6440feeeca3ab7183c6c345d4d1a2e0e4f7bc52b265455636ae8e07ddbed0e182c8d0b326b7686cdeda97500203fe3183 SHA512 cb1a09fea7ed2bb74c0c3f5a525d35ef7304dc2c569c6c808cd3751e500b7e32f226436ec4150f63a8280bc3f0c53dfd64757aa09da7344b1ec998130006253c
diff --git a/dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-0.11.1.ebuild b/dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-0.11.1.ebuild
new file mode 100644
index 000000000000..3266f4d20f9f
--- /dev/null
+++ b/dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-0.11.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/lagadic/vision_visp"
+KEYWORDS="~amd64 ~arm"
+VER_PREFIX="kinetic-"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python{2_7,3_5} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Estimates the camera position with respect to its effector using the ViSP library"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/image_proc
+ dev-ros/roscpp
+ dev-ros/sensor_msgs
+ dev-ros/visp_bridge
+ dev-ros/visp_tracker
+ sci-libs/ViSP:=
+"
+DEPEND="${RDEPEND}"
+if [ "${PV#9999}" = "${PV}" ] ; then
+ S="${WORKDIR}/vision_visp-kinetic-${PV}/${ROS_SUBDIR}"
+fi