summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-28 16:06:33 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-29 14:19:42 +0200
commit0d6f14c352fd2713ac35a1abb2fe1cce44e6b532 (patch)
treefdc36bea18ab456369becb09ccd20642f6a1b167 /dev-ros/unique_id
parentdev-ros/test_rosservice: convert to python-single-r1 (diff)
downloadgentoo-0d6f14c352fd2713ac35a1abb2fe1cce44e6b532.tar.gz
gentoo-0d6f14c352fd2713ac35a1abb2fe1cce44e6b532.tar.bz2
gentoo-0d6f14c352fd2713ac35a1abb2fe1cce44e6b532.zip
dev-ros/unique_id: convert to python-single-r1
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/unique_id')
-rw-r--r--dev-ros/unique_id/unique_id-1.0.6.ebuild7
-rw-r--r--dev-ros/unique_id/unique_id-9999.ebuild7
2 files changed, 10 insertions, 4 deletions
diff --git a/dev-ros/unique_id/unique_id-1.0.6.ebuild b/dev-ros/unique_id/unique_id-1.0.6.ebuild
index 7ff69d0fac63..3614a9ea3228 100644
--- a/dev-ros/unique_id/unique_id-1.0.6.ebuild
+++ b/dev-ros/unique_id/unique_id-1.0.6.ebuild
@@ -16,9 +16,12 @@ IUSE=""
RDEPEND="
dev-ros/uuid_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
dev-ros/roscpp
"
DEPEND="${RDEPEND}
dev-ros/uuid_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- test? ( dev-cpp/gtest dev-python/nose[${PYTHON_USEDEP}] )"
+ test? (
+ dev-cpp/gtest
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )"
diff --git a/dev-ros/unique_id/unique_id-9999.ebuild b/dev-ros/unique_id/unique_id-9999.ebuild
index 7ff69d0fac63..3614a9ea3228 100644
--- a/dev-ros/unique_id/unique_id-9999.ebuild
+++ b/dev-ros/unique_id/unique_id-9999.ebuild
@@ -16,9 +16,12 @@ IUSE=""
RDEPEND="
dev-ros/uuid_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
dev-ros/roscpp
"
DEPEND="${RDEPEND}
dev-ros/uuid_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- test? ( dev-cpp/gtest dev-python/nose[${PYTHON_USEDEP}] )"
+ test? (
+ dev-cpp/gtest
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )"