summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 18:56:05 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 19:04:24 +0200
commita6cb5fed2a5a4367e8fc11adecc913f93aba9ca2 (patch)
treeb7739dfc9b238f80e04a303a13f8d6256a3be9a7 /dev-ros/tf/tf-9999.ebuild
parentdev-ros/test_tf2: Initial import. Ebuild by me. (diff)
downloadgentoo-a6cb5fed2a5a4367e8fc11adecc913f93aba9ca2.tar.gz
gentoo-a6cb5fed2a5a4367e8fc11adecc913f93aba9ca2.tar.bz2
gentoo-a6cb5fed2a5a4367e8fc11adecc913f93aba9ca2.zip
dev-ros/tf: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/tf/tf-9999.ebuild')
-rw-r--r--dev-ros/tf/tf-9999.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ros/tf/tf-9999.ebuild b/dev-ros/tf/tf-9999.ebuild
new file mode 100644
index 000000000000..f81e4ccc6abe
--- /dev/null
+++ b/dev-ros/tf/tf-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/geometry"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Maintains the relationship between coordinate frames in a tree structure buffered in time"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/angles
+ dev-ros/message_filters
+ dev-ros/rosconsole
+ dev-ros/rostime
+ dev-ros/roscpp
+ dev-ros/tf2_ros
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-cpp/gtest
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"